ACM-对称博弈之Coin Game——hdu3951

Coin Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1145    Accepted Submission(s): 668

Problem Description
After hh has learned how to play Nim game, he begins to try another coin game which seems much easier.

The game goes like this: 
Two players start the game with a circle of n coins. 
They take coins from the circle in turn and every time they could take 1~K continuous coins. 
(imagining that ten coins numbered from 1 to 10 and K equal to 3, since 1 and 10 are continuous, you could take away the continuous 10 , 1 , 2 , but if 2 was taken away, you couldn't take 1, 3, 4, because 1 and 3 aren't continuous)
The player who takes the last coin wins the game. 
Suppose that those two players always take the best moves and never make mistakes. 
Your job is to find out who will definitely win the game.
 
Input
The first line is a number T(1<=T<=100), represents the number of case. The next T blocks follow each indicates a case.
Each case contains two integers N(3<=N<=10 9,1<=K<=10).
 
Output
For each case, output the number of case and the winner "first" or "second".(as shown in the sample output)
 
Sample Input
  
  
2 3 1 3 2
 
Sample Output
  
  
Case 1: first Case 2: second
 
Author
NotOnlySuccess
 
Source
 


又是一道博大精深的博弈题目。
已经说了 巴什博弈威佐夫博弈尼姆博弈SG函数找规律的博弈,这次和找规律有点类似——对称博弈。
一般都是圆啊方啊什么的。

对于这道题而言,可以有三种情况:
①k等于1    一次最多只能拿1个(每堆只有一个),那就是看奇偶了。
②n≤k  这种情况,那肯定先拿的赢。
③ 这条就是对称博弈了, 除了上述两种情况外的情况(n>k && k!=1)
    这时候,无论你第一个人拿什么,怎么拿,后手的人完全可以在第一个人拿的对称的地方做同样的事情。
这样,后手就一定会取得胜利,因为最后一步是后手走的。

第三条自己在本上画一画就不难发现了。

恩,博弈论,暂时就先到这里了。。。。


代码:
/**************************************
***************************************
*        Author:Tree                  *
*From :http://blog.csdn.net/lttree    *
* Title : Coin Game              *
*Source: hdu 3951                     *
* Hint  : 对称博弈                   *
***************************************
**************************************/
#include <stdio.h>
int main()
{
    int t,i,n,k;
    scanf("%d",&t);
    for( i=1;i<=t;++i )
    {
        scanf("%d%d",&n,&k);
        printf("Case %d: ",i);
        if( k==1 )
        {
            if( n&1 )   printf("first\n");
            else    printf("second\n");
        }
        else if( n<=k ) printf("first\n");
        else    printf("second\n");
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值