HDU 6343 Problem L. Graph Theory Homework (思维)

hdu 6343

There is a complete graph containing n vertices, the weight of the i-th vertex is wi.
The length of edge between vertex i and j (i≠j) is .
Calculate the length of the shortest path from 1 to n

.

Input

The first line of the input contains an integer T

(1≤T≤10)

denoting the number of test cases.
Each test case starts with an integer n (1≤n≤105) denoting the number of vertices in the graph.
The second line contains n integers, the i-th integer denotes wi (1≤wi≤105)

.

Output

For each test case, print an integer denoting the length of the shortest path from 1

to n

.

Sample Input

1
3
1 3 5

Sample Output

2

从前一个点可以任意选择下一个点, 每个点有一个权值, 点和点之间的距离是,权值差的绝对值开根号再向下取整,求从1 到n最短距离。

刚开始做这个题, 觉得是个水题, (实际上确实是个水题),写了个 n ^ 2的记忆化搜索, 抱着侥幸心理交了一次, 不出意外的超时了~

实际上我们可以假设有某中间点k, 使得直接从1到n的路线松弛, 那么有

两边平方就会发现, k的存在是矛盾的,所以知道最短距离是从1直接到n。

AC代码:

#include<cstdio>
#include<iostream>
#include<cmath>
using namespace std;
int main()
{
    int i, j, T, ans, n, q, m;
    int s[100005];
    scanf("%d", &T);
    while(T--){
        scanf("%d", &n);
        for(i = 1;i <= n;i++)
            scanf("%d", &a);
        m = abs(s[1] - s[n]);
        ans = (int)sqrt(m * 1.0);
        printf("%d\n", ans);
    }
    return 0;
}

 

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值