Hero贪心2------[NWPU][2018寒假作业][通用版]二Q题

When playing DotA with god-like rivals and pig-like team members, you have to face an embarrassing situation: All your teammates are killed, and you have to fight 1vN.
There are two key attributes for the heroes in the game, health point (HP) and damage per shot (DPS). Your hero has almost infinite HP, but only 1 DPS.
To simplify the problem, we assume the game is turn-based, but not real-time. In each round, you can choose one enemy hero to attack, and his HP will decrease by 1. While at the same time, all the lived enemy heroes will attack you, and your HP will decrease by the sum of their DPS. If one hero’s HP fall equal to (or below) zero, he will die after this round, and cannot attack you in the following rounds.
Although your hero is undefeated, you want to choose best strategy to kill all the enemy heroes with minimum HP loss.
Input
The first line of each test case contains the number of enemy heroes N (1 <= N <= 20). Then N lines followed, each contains two integers DPSi and HPi, which are the DPS and HP for each hero. (1 <= DPSi, HPi <= 1000)
Output
Output one line for each test, indicates the minimum HP loss.
Sample Input
1
10 2
2
100 1
1 100
Sample Output
20
201

解题思路:
这道题和上一道Doing Homework Again 类似。都是先排序,再按顺序进行计算。
那应该如何排序呢?首先找出题目中两个影响结果的主要因素,dps和hp。显然,应该先消灭dps大hp小的英雄。dps和hp两个因素同等重要,想用一个因素表示两个因素,只能选择比值或者乘积。于是用dps/hp由大到小排序。

要注意int/int会自动取整的,没注意这个,所以一个WA。

#include<stdio.h>
#include<algorithm>
#include<iostream>
using namespace std;

struct node
{
    double dps;
    double hp;
    double point;
}hero[1010];

bool cmp(node x,node y)
{
    return x.point>y.point;
}

int main()
{
    int n,min,sum;
    while(scanf("%d",&n)!=EOF)
    {
        sum=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%lf%lf",&hero[i].dps,&hero[i].hp);
            hero[i].point=hero[i].dps/hero[i].hp;
            sum+=hero[i].dps;
        }
        sort(hero+1,hero+1+n,cmp);
        min=0;
        for(int i=1;i<=n;i++)
        {
            min+=sum*hero[i].hp;
            sum-=hero[i].dps;
        }
        printf("%d\n",min);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值