HDU - 1595 find the longest of the shortest(如何在所有的路中,一条条去除是和去除那些边是关键)

题目链接https://vjudge.net/contest/325616#problem/E

Problem Description
Marica is very angry with Mirko because he found a new girlfriend and she seeks revenge.Since she doesn’t live in the same city, she started preparing for the long journey.We know for every road how many minutes it takes to come from one city to another.Mirko overheard in the car that one of the roads is under repairs, and that it is blocked, but didn’t konw exactly which road. It is possible to come from Marica’s city to Mirko’s no matter which road is closed.Marica will travel only by non-blocked roads, and she will travel by shortest route. Mirko wants to know how long will it take for her to get to his city in the worst case, so that he could make sure that his girlfriend is out of town for long enough.Write a program that helps Mirko in finding out what is the longest time in minutes it could take for Marica to come by shortest route by non-blocked roads to his city.
Input
Each case there are two numbers in the first row, N and M, separated by a single space, the number of towns,and the number of roads between the towns. 1 ≤ N ≤ 1000, 1 ≤ M ≤ N*(N-1)/2. The cities are markedwith numbers from 1 to N, Mirko is located in city 1, and Marica in city N.
In the next M lines are three numbers A, B and V, separated by commas. 1 ≤ A,B ≤ N, 1 ≤ V ≤ 1000.Those numbers mean that there is a two-way road between cities A and B, and that it is crossable in V minutes.
Output
In the first line of the output file write the maximum time in minutes, it could take Marica to come to Mirko.
Sample Input

5 6
1 2 4
1 3 3
2 3 1
2 4 4
2 5 7
4 5 1

6 7
1 2 1
2 3 4
3 4 4
4 6 4
1 5 5
2 5 2
5 6 5

5 7
1 2 8
1 4 10
2 3 9
2 4 10
2 5 1
3 4 7
3 5 10 

Sample Output

11
13
27

翻译
给定n,m,表示n个点,m条路,接下来有m条路(双向的)。去除任意一条路,保证能从1到n,求出一条最短路,求所有最短路中,所消耗的最大时间是多少?
分析
最短路用Dijkstra即可求得,此题的关键是,如何一条条去除路,并求出此时最短路所花费的时间?
解决办法
在Dijkstra更新路径时,可以用pre[]数组,来记录相邻两点的关系去除一条边,将这条边标记为INF即可。每次去除一条边之后,找最短路,若去除的边不在最初的最短路上,那么最短路是不变的,所以不在最短路上的边就不用管了,即去除的边,去除最短路上的边即可(去除最短路上的边才可能引起最短路的变化)
代码

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define N 10001
#define INF 0x3f3f3f3f
int e[N][N],book[N],dis[N];
int pre[N];
int n,flag,m;
int MX;
void init()
{
    MX=-1;
    flag=0;
    for(int i=1; i<=n; i++)
    {
        for(int j=1; j<=n; j++)
        {
            if(i==j)
                e[i][j]=0;
            else
                e[i][j]=INF;
        }
        pre[i]=1;/*标记*/
    }
    for(int i=0; i<m; i++)
    {
        int a,b,c;
        scanf("%d%d%d",&a,&b,&c);
        if(e[a][b]>c)
        {
            e[a][b]=c;
            e[b][a]=c;
        }
    }
}
void Dijkstra()/*求出一条最短路*/
{
    for(int i=1; i<=n; i++)
        dis[i]=e[1][i];  /*如何减去某一条路是关键*/
    memset(book,0,sizeof(book));
    book[1]=1;
    for(int i=1; i<n; i++)
    {
        int mx=INF,u;
        for(int j=1; j<=n; j++)
        {
            if(dis[j]<mx&&book[j]==0)
            {
                mx=dis[j];
                u=j;
            }
        }
        book[u]=1;
        for(int k=1; k<=n; k++)
        {
            if(dis[k]>dis[u]+e[u][k])
            {
                dis[k]=dis[u]+e[u][k];
                if(flag==0)
                {
                     pre[k]=u;
                    //printf("pre[%d]=%d\n",k,u);
                }

            }
        }
    }
    if(dis[n]<INF)
        MX=max(dis[n],MX);/*所有的最短路中找出时间最大的*/
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        init();
        Dijkstra();
        flag=1;
        int s=n;
        pre[1]=0;
        while(pre[s]!=0)
        {
            int vis=e[s][pre[s]];
            e[s][pre[s]]=INF;
            e[pre[s]][s]=INF;
            Dijkstra();
            e[s][pre[s]]=vis;
            e[pre[s]][s]=vis;
            s=pre[s];
        }
        printf("%d\n",MX);
    }
    return 0;
}

风轻云淡

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

zaiyang遇见

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值