HDU 1595 find the longest of the shortest (Dijkstra)

66 篇文章 0 订阅
15 篇文章 0 订阅

find the longest of the shortest

Time Limit: 1000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2054    Accepted Submission(s): 720


Problem Description
Marica is very angry with Mirko because he found a new girlfriend and she seeks revenge.Since she doesn't live in the same city, she started preparing for the long journey.We know for every road how many minutes it takes to come from one city to another.
Mirko overheard in the car that one of the roads is under repairs, and that it is blocked, but didn't konw exactly which road. It is possible to come from Marica's city to Mirko's no matter which road is closed.
Marica will travel only by non-blocked roads, and she will travel by shortest route. Mirko wants to know how long will it take for her to get to his city in the worst case, so that he could make sure that his girlfriend is out of town for long enough.Write a program that helps Mirko in finding out what is the longest time in minutes it could take for Marica to come by shortest route by non-blocked roads to his city.
 


 

Input
Each case there are two numbers in the first row, N and M, separated by a single space, the number of towns,and the number of roads between the towns. 1 ≤ N ≤ 1000, 1 ≤ M ≤ N*(N-1)/2. The cities are markedwith numbers from 1 to N, Mirko is located in city 1, and Marica in city N.
In the next M lines are three numbers A, B and V, separated by commas. 1 ≤ A,B ≤ N, 1 ≤ V ≤ 1000.Those numbers mean that there is a two-way road between cities A and B, and that it is crossable in V minutes.
 


 

Output
In the first line of the output file write the maximum time in minutes, it could take Marica to come to Mirko.
 


 

Sample Input
  
  
5 6 1 2 4 1 3 3 2 3 1 2 4 4 2 5 7 4 5 1 6 7 1 2 1 2 3 4 3 4 4 4 6 4 1 5 5 2 5 2 5 6 5 5 7 1 2 8 1 4 10 2 3 9 2 4 10 2 5 1 3 4 7 3 5 10
 


 

Sample Output
  
  
11 13 27
 

简单的说就是。在所有路径中,断掉其中一条,再求最短路径,枚举所有路径断掉的情况。计算这些路径中的最短路径中的最长的那条。
只要在记录的路径中。枚举每条路径为一无穷大的值,计算最短路径,然后去计算的结果的最大的一个就可以。

#include "stack"
#include "cstdio"
#include "iostream"
#include "cmath"
#include "set"
#include "sstream"
#include "cctype"
#include "string"
#include "cstring"
#include "algorithm"
#include "queue"
//#include "map"
using namespace std;
#define LL long long
#define inf 0x7ffffff
#define pa pair<int,int>
#define pi 3.1415926535897932384626433832795028841971

const int M = 1050;

int n, m;
int map[M][M];
int dis[M], vis[M], road[M];

void Dijkstra(int s, int flag)
{
	int i, j, p, min;
	memset(vis, 0, sizeof(vis));
	for (i = 0; i <= n; i++)
		dis[i] = inf;
	dis[s] = 0;
	for (i = 1; i <= n; i++)
	{
		min = inf;
		for (j = 1; j <= n; j++)
		{
			if (dis[j] < min && !vis[j])
				min = dis[p = j];
		}
		vis[p] = 1;
		for (j = 1; j <= n; j++)
			if (dis[p] + map[p][j] < dis[j])
			{
				dis[j] = dis[p] + map[p][j];
				if (flag)
					road[j] = p;
			}
	}
}

int main()
{
	int i, j;
	while (~scanf("%d%d", &n, &m))
	{
		for (i = 0; i <= n; i++)
		{
			for (j = 0; j <= n; j++)
				map[i][j] = inf;
			map[i][i] = 0;
		}
		for (i = 0; i < m; i++)
		{
			int a, b, c;
			scanf("%d%d%d", &a, &b, &c);
			if (c < map[a][b])
				map[a][b] = map[b][a] = c;
		}
		memset(road, 0, sizeof(road));

		Dijkstra(1, 1);

		int ans = dis[n];
		int cnt;
		for (i = n; i != 1; i = road[i])
		{
			cnt = map[i][road[i]];
			map[i][road[i]] = map[road[i]][i] = inf;
			Dijkstra(1, 0);
			ans = max(ans, dis[n]);
			map[i][road[i]] = map[road[i]][i] = cnt;
		}
		printf("%d\n", ans);
	}

	return 0;
}


 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值