HDU - 5120 Intersection(求两圆环相交面积)

题目链接https://vjudge.net/contest/368031#problem/B

Matt is a big fan of logo design. Recently he falls in love with logo made up by rings. The following figures are some famous examples you may know.
在这里插入图片描述
A ring is a 2-D figure bounded by two circles sharing the common center. The radius for these circles are denoted by r and R (r < R). For more details, refer to the gray part in the illustration below.

在这里插入图片描述
Matt just designed a new logo consisting of two rings with the same size in the 2-D plane. For his interests, Matt would like to know the area of the intersection of these two rings.

Input
The first line contains only one integer T (T ≤ 105), which indicates the number of test cases. For each test case, the first line contains two integers r, R (0 ≤ r < R ≤ 10).

Each of the following two lines contains two integers x i, y i (0 ≤ x i, y i ≤ 20) indicating the coordinates of the center of each ring.
Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y is the area of intersection rounded to 6 decimal places.
Sample Input

2
2 3
0 0
0 0
2 3
0 0
5 0

Sample Output


```handlebars
Case #1: 15.707963
Case #2: 2.250778

翻译
每一组数据由3行组成。
第一行的两个数分别表示小圆和大圆的半径。
第二行和第三行分别表示两圆环的圆心坐标。
求,两相同圆环的相交的面积。
分析
根据圆心之间的距离和半径的关系,将两圆环的相交转化为两圆的相交。

知识点
  1. 求面积是π的取值#define PI acos(-1.0),不应该写成3.14159

  2. 两个浮点数的比较大小需要借助const double eps=1e-8;来进行比较。

  3. 求两圆相交面积的模板。

代码

#include<cstdio>
#include<cstring>
#include<stdlib.h>
#include<algorithm>
#include<cmath>
using namespace std;
#define PI acos(-1.0)/*3.1415926*/
const double eps=1e-8;
double r,R;
double solve(double dis,double x1,double y1,double r1,double x2,double y2,double r2)
{
    if(r1+r2<eps+dis)/*相离*/
        return 0;
    if(dis<fabs(r1-r2)+eps)/*小圆完全在大圆里面*/
    {
        double r=min(r1,r2);
        return PI*r*r;
    }
    double x=(dis*dis+r1*r1-r2*r2)/(2*dis);
    double t1=acos(x/r1);
    double t2=acos((dis-x)/r2);
    return r1*r1*t1+r2*r2*t2-dis*r1*sin(t1);
}
int main()
{
    int t;
    scanf("%d",&t);
    int f=1;
    double x1,y1,x2,y2;
    while(t--)
    {
        scanf("%lf%lf",&r,&R);
        scanf("%lf%lf%lf%lf",&x1,&y1,&x2,&y2);
        printf("Case #%d: ",f++);
        double dis=sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));/*两圆心之间的距离*/
        if(dis-2*R>=eps)/*外面两大圆的关系为相离*/
            printf("0.000000\n");
        else if(dis-(R+r)>=eps)/*圆环的大圆和另一个圆环的小圆相切,此时的相交面积只和大圆有关,和小圆无关*/
            printf("%.6lf\n",solve(dis,x1,y1,R,x2,y2,R));
        else
            printf("%.6lf\n",solve(dis,x1,y1,R,x2,y2,R)-solve(dis,x1,y1,R,x2,y2,r)-solve(dis,x1,y1,r,x2,y2,R)+solve(dis,x1,y1,r,x2,y2,r));/*两个大圆相交的面积-2*大圆与小圆相交的面积+两个小圆的相交面积*/
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

zaiyang遇见

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值