1114. Family Property (25)

1114. Family Property (25)

时间限制
150 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

This time, you are supposed to help us collect the data for family-owned property. Given each person's family members, and the estate(房产)info under his/her own name, we need to know the size of each family, and the average area and number of sets of their real estate.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=1000). Then N lines follow, each gives the infomation of a person who owns estate in the format:

ID Father Mother k Child1 ... Childk M_estate Area

where ID is a unique 4-digit identification number for each person; Father and Mother are the ID's of this person's parents (if a parent has passed away, -1 will be given instead); k (0<=k<=5) is the number of children of this person; Childi's are the ID's of his/her children; M_estateis the total number of sets of the real estate under his/her name; and Area is the total area of his/her estate.

Output Specification:

For each case, first print in a line the number of families (all the people that are related directly or indirectly are considered in the same family). Then output the family info in the format:

ID M AVG_sets AVG_area

where ID is the smallest ID in the family; M is the total number of family members; AVG_sets is the average number of sets of their real estate; and AVG_area is the average area. The average numbers must be accurate up to 3 decimal places. The families must be given in descending order of their average areas, and in ascending order of the ID's if there is a tie.

Sample Input:
10
6666 5551 5552 1 7777 1 100
1234 5678 9012 1 0002 2 300
8888 -1 -1 0 1 1000
2468 0001 0004 1 2222 1 500
7777 6666 -1 0 2 300
3721 -1 -1 1 2333 2 150
9012 -1 -1 3 1236 1235 1234 1 100
1235 5678 9012 0 1 50
2222 1236 2468 2 6661 6662 1 300
2333 -1 3721 3 6661 6662 6663 1 100
Sample Output:
3
8888 1 1.000 1000.000
0001 15 0.600 100.000
5551 4 0.750 100.000

连通分量问题,采用dfs


#include<stdio.h>
#include<math.h>
#include<vector>
#include<algorithm>
using namespace std;
vector<int>adj[10010];
vector<int>name;
int visit[10010];
int personsum,estatesum,areasum,maxid,cou;
struct node{
	int estate;
	int area;
}stu[10010];
struct node2{
	int id;
	int personnum;
	double avgestate;
	double avgarea;
};
vector<node2>ans;
void init(){
	int i;
	personsum=0;
	estatesum=0;
	areasum=0;
//	for(i=0;i<10010;i++){
//		visit[i]=0;
//	}
}
void dfs(int s){
	visit[s]=1;
	personsum++;
	estatesum=estatesum+stu[s].estate;
	areasum=areasum+stu[s].area;
	if(s<maxid){
		maxid=s;
	}
	int i;
	for(i=0;i<adj[s].size();i++){
		int next=adj[s][i];
		if(visit[next]==0){
			dfs(next);
		}
	}
}
void dfstravel(){
	int i;
	for(i=0;i<name.size();i++){
		if(visit[name[i]]==0){
			cou++;
			personsum=0;
			estatesum=0;
			areasum=0;
			maxid=10010;
			dfs(name[i]);
			node2 temp={maxid,personsum,(double)estatesum/personsum,(double)areasum/personsum};
			ans.push_back(temp);
		}
	}
}
bool comp(node2 a,node2 b){
	if(fabs(a.avgarea-b.avgarea)>0.00001){
		return a.avgarea>b.avgarea;
	}
	else{
		return a.id<b.id;
	}
}
int main(){
	int n,i,j,k,p1,p2,p3,p4;
	scanf("%d",&n);
	for(i=0;i<n;i++){
		scanf("%d %d %d %d",&p1,&p2,&p3,&k);
		name.push_back(p1);
		if(p2!=-1){
			name.push_back(p2);
			adj[p1].push_back(p2);
			adj[p2].push_back(p1);
		}
		if(p3!=-1){
			name.push_back(p3);
			adj[p1].push_back(p3);
			adj[p3].push_back(p1);
		}
		for(j=0;j<k;j++){
			scanf("%d",&p4);
			name.push_back(p4);
			adj[p1].push_back(p4);
			adj[p4].push_back(p1);
		}
		scanf("%d %d",&stu[p1].estate,&stu[p1].area);
	}
	dfstravel();
	sort(ans.begin(),ans.end(),comp);
	printf("%d\n",cou);
//	printf("%d\n",ans.size());
	for(i=0;i<cou;i++){
		printf("%04d %d %.3lf %.3lf\n",ans[i].id,ans[i].personnum,ans[i].avgestate,ans[i].avgarea);
	}
} 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值