1126. Eulerian Path (25)

1126. Eulerian Path (25)

时间限制
300 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous Seven Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are called Eulerian. If there are exactly two vertices of odd degree, all Eulerian paths start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is called semi-Eulerian. (Cited from https://en.wikipedia.org/wiki/Eulerian_path)

Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N (<= 500), and M, which are the total number of vertices, and the number of edges, respectively. Then M lines follow, each describes an edge by giving the two ends of the edge (the vertices are numbered from 1 to N).

Output Specification:

For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph -- either "Eulerian", "Semi-Eulerian", or "Non-Eulerian". Note that all the numbers in the first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.

Sample Input 1:
7 12
5 7
1 2
1 3
2 3
2 4
3 4
5 2
7 6
6 3
4 5
6 4
5 6
Sample Output 1:
2 4 4 4 4 4 2
Eulerian
Sample Input 2:
6 10
1 2
1 3
2 3
2 4
3 4
5 2
6 3
4 5
6 4
5 6
Sample Output 2:
2 4 4 4 3 3
Semi-Eulerian
Sample Input 3:
5 8
1 2
2 5
5 4
4 1
1 3
3 2
3 4
5 3
Sample Output 3:
3 3 4 3 3
Non-Eulerian

注意判断图的连通性

为什么方法二测试点3 4 错误呢?希望dalao看出来能交流下...

明白了。。。 方法二图不连通忘记输出每个结点度了。。。

方法三对方法二修改。。。


方法一:

#include<stdio.h>
#include<vector>
using namespace std;
int n,m,cnt;
vector<int>adj[510];
int degree[510];
int visit[510];
int cou=0;
void dfs(int s){
	cnt++;
	visit[s]=1;
	int i;
	for(i=0;i<adj[s].size();i++){
		int next=adj[s][i];
		if(visit[next]==0){
			dfs(next);
		}
	}
}
void dfstravel(){
	int i;
	for(i=1;i<=n;i++){
		if(visit[i]==0){
			cou++;
			dfs(i);
		}
	}
}
int main(){
	int i,c1,c2;
	scanf("%d %d",&n,&m);
	for(i=0;i<m;i++){
		scanf("%d %d",&c1,&c2);
		adj[c1].push_back(c2);
		adj[c2].push_back(c1);
		degree[c1]++;
		degree[c2]++;
	}
	for(i=1;i<=n;i++){
		printf("%d",degree[i]);
		if(i!=n){
			printf(" ");
		}
	}
	printf("\n");
	int even=1,oddnum=0;
	for(i=1;i<=n;i++){
		if(degree[i]%2!=0){
			even=0;
			oddnum++;
		}
	}
	dfstravel();
	if(cou!=1){
		printf("Non-Eulerian");return 0;
	}
	if(even){
		printf("Eulerian");
	}
	else if(oddnum==2){
		printf("Semi-Eulerian");
	}
	else{
		printf("Non-Eulerian");
	}
}

方法二:测试点3 4错误

#include<stdio.h>
int n,m,cou,cnt;
int degree[510];
int exist[510];
int visit[510];
int adj[510][510];
void dfs(int s){
	if(visit[s]==1){
		return;
	}
	visit[s]=1;
	cou++;
	for(int i=1;i<=n;i++){
		if(adj[s][i]){
			dfs(i);
		}
	}
}
int main(){
	int i,c1,c2;
	scanf("%d %d",&n,&m);
	for(i=0;i<m;i++){
		scanf("%d %d",&c1,&c2);
		exist[c1]=exist[c2]=1;
		adj[c1][c2]=adj[c2][c1]=1;
		degree[c1]++;
		degree[c2]++;
	}
	for(i=1;i<=n;i++){
		if(exist[i]){//统计 出现过的点数 
			cnt++;
		}
	} 
	dfs(c1);
	if(cou!=cnt){
		printf("Non-Eulerian");
	}
	else{
		int even=0,odd=0,oddindex;
		for(i=1;i<=n;i++){
			printf("%d",degree[i]);
			if(i!=n){
				printf(" ");
			}
			if(degree[i]%2){
				odd++;
				oddindex=i;
			}
			else{
				even++;// 
			}
		}
		printf("\n");
		if(odd==0){
			printf("Eulerian");
		}
		else if(odd==2){//...
//			cou=0;
//			for(i=1;i<=n;i++){
//				visit[i]=0;
//			}
//			dfs(oddindex);
//			if(cou==n){
				printf("Semi-Eulerian");
//			}
//			else{
//				printf("Non-Eulerian");//测试点4 
//			}			
		}
		else{
			printf("Non-Eulerian");
		}
	}
}

方法三:对方法二修改。。。

#include<stdio.h>
int n,m,cou,cnt;
int degree[510];
int exist[510];
int visit[510];
int adj[510][510];
void dfs(int s){
	if(visit[s]==1){
		return;
	}
	visit[s]=1;
	cou++;
	for(int i=1;i<=n;i++){
		if(adj[s][i]){
			dfs(i);
		}
	}
}
int main(){
	int i,c1,c2;
	scanf("%d %d",&n,&m);
	for(i=0;i<m;i++){
		scanf("%d %d",&c1,&c2);
		exist[c1]=exist[c2]=1;
		adj[c1][c2]=adj[c2][c1]=1;
		degree[c1]++;
		degree[c2]++;
	}
//	for(i=1;i<=n;i++){
//		if(exist[i]){//统计 出现过的点数 
//			cnt++;
//		}
//	} 
	dfs(1);
//	if(cnt!=n);//while(1);//测试点4 
//	if(cou!=n){
//		printf("Non-Eulerian");
//	}
//	else{
		int even=1,odd=0;
		for(i=1;i<=n;i++){
			printf("%d",degree[i]);
			if(i!=n){
				printf(" ");
			}
			if(degree[i]%2){
				odd++;
				even=0;
			}
		}
		printf("\n");
		if(cou!=n){
			printf("Non-Eulerian");return 0;
		}
		if(even){
			printf("Eulerian");
		}
		else if(odd==2){
			printf("Semi-Eulerian");		
		}
		else{
			printf("Non-Eulerian");
		}
	}
//}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
好的,下面是更加复杂的代码,它可以对无向图或有向图进行欧拉路径/欧拉回路的查找,并考虑了多种情况,每一步都有注释说明: ```python import networkx as nx # 创建一个图G G = nx.DiGraph() # 如果是无向图,则使用nx.Graph() # 添加节点和边 G.add_edges_from([(1,2),(1,3),(2,3),(2,4),(3,4),(3,5),(4,5),(5,1)]) # 判断图是否是欧拉图 if nx.is_eulerian(G): # 判断图是否是欧拉回路 if nx.is_eulerian(G): # 如果是欧拉回路,则找到回路并打印 euler_circuit = list(nx.eulerian_circuit(G)) print("欧拉回路为:", euler_circuit) else: # 如果是欧拉路径,则找到路径并打印 euler_path = list(nx.eulerian_path(G)) print("欧拉路径为:", euler_path) else: # 如果图不是欧拉图,则查找是否有欧拉通路 odd_nodes = [v for v, d in G.degree() if d % 2 == 1] # 找到度数为奇数的节点 if len(odd_nodes) == 2: # 如果有两个度数为奇数的节点,则找到欧拉通路并打印 start_node = odd_nodes[0] end_node = odd_nodes[1] euler_path = list(nx.eulerian_path(G, start_node)) print("欧拉通路为:", euler_path) else: # 如果没有欧拉通路,则打印相应信息 print("图不存在欧拉路径或欧拉回路") ``` 这个程序同样使用了Python中的networkx库,可以方便地创建和操作图。程序中首先创建了一个有向图G,并添加了节点和边。然后使用`nx.is_eulerian(G)`函数判断图G是否是欧拉图。如果是欧拉图,则使用`nx.is_eulerian(G)`函数判断图G是否是欧拉回路。如果是欧拉回路,则使用`nx.eulerian_circuit(G)`函数找到欧拉回路,并将其存储在列表`euler_circuit`中,最后输出欧拉回路。如果不是欧拉回路,则使用`nx.eulerian_path(G)`函数找到欧拉路径,并将其存储在列表`euler_path`中,最后输出欧拉路径。如果图不是欧拉图,则查找是否有欧拉通路。找到度数为奇数的节点,并判断它们的数量。如果有两个度数为奇数的节点,则使用`nx.eulerian_path(G, start_node)`函数找到欧拉通路,并将其存储在列表`euler_path`中,最后输出欧拉通路。如果没有欧拉通路,则输出相应信息。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值