1126 Eulerian Path (25分) 测试点3

In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous Seven Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are called Eulerian. If there are exactly two vertices of odd degree, all Eulerian paths start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is called semi-Eulerian. (Cited from https://en.wikipedia.org/wiki/Eulerian_path)

Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N (≤ 500), and M, which are the total number of vertices, and the number of edges, respectively. Then M lines follow, each describes an edge by giving the two ends of the edge (the vertices are numbered from 1 to N).

Output Specification:

For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph – either Eulerian, Semi-Eulerian, or Non-Eulerian. Note that all the numbers in the first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.

Sample Input 1:

7 12
5 7
1 2
1 3
2 3
2 4
3 4
5 2
7 6
6 3
4 5
6 4
5 6
Sample Output 1:

2 4 4 4 4 4 2
Eulerian
Sample Input 2:

6 10
1 2
1 3
2 3
2 4
3 4
5 2
6 3
4 5
6 4
5 6
Sample Output 2:

2 4 4 4 3 3
Semi-Eulerian
Sample Input 3:

5 8
1 2
2 5
5 4
4 1
1 3
3 2
3 4
5 3
Sample Output 3:

3 3 4 3 3
Non-Eulerian

分析:根据节点的度数区分图的类型。该题认为是无向图,欧拉图:节点度数为偶数,半欧拉图:只有两个节点度数为奇数,其他为偶数,否则为非欧拉图(包括不是连通图的情况)

测试点3就是非连通图的情况。所以要先用dfs判断连通分量的个数,为1是连通图,否则不是。

代码如下:

#include<iostream>
#include<cstring>
#include<algorithm>
#include<vector>
using namespace std;
vector<int> v[501];		//用邻接表存储图节点,放便后续判断连通分量
int n,m;			//节点n,边m
int vis[501];	//标记是否访问过
void dfs(int x){
    vis[x] = 1;
    for (int i = 0; i < v[x].size(); ++i)
    {
        if(!vis[v[x][i]]){
            dfs(v[x][i]);
        }
    }

}
int main(int argc, char const *argv[])
{
    cin>>n>>m;
    int cot[501] = {0};
    fill(vis,vis+501,0);
    for (int i = 0; i < m; ++i)
    {
        
            int a,b;
            cin>>a>>b;
            cot[a]++;
            cot[b]++;
            v[a].push_back(b);		
            v[b].push_back(a);
        
    }  
    int sum = 0;
    for (int i = 1; i <= n; ++i)
    {
        if(!vis[i]){
            dfs(i);
            sum++;
        }
    }
    cout<<cot[1];		//优化:可以直接根据每个节点的后续节点数判断,不用单独存储v[i].size()
    int flag = cot[1]%2; 
    for (int i = 2; i <= n; ++i)
    {
        cout<<' '<<cot[i];
        if(cot[i]%2){
            flag++;
        }
    }
    cout<<endl;
    //cout<<sum<<endl;
    if(sum == 1){
        if(flag == 2){
            cout<<"Semi-Eulerian"<<endl;
        }else if(flag == 0){
            cout<<"Eulerian"<<endl;
        }else{
            cout<<"Non-Eulerian"<<endl;
        }
    }else{
        cout<<"Non-Eulerian"<<endl;
    }

    return 0;
}

欧拉图

欧拉回路:图G中经过每条边一次并且仅一次的回路称作欧拉回路
欧拉通路:图G中经过每条边一次并且仅一次的路径称作欧拉通路。
欧拉图(Eulerian graph)指的就是存在欧拉回路的图。
半欧拉图(semi-Eulerian graph)指的是存在欧拉通路但不存在欧拉回路的图。

1.无向图中:
无向图G为欧拉图,当且仅当G为连通图且所有顶点的度为偶数。
  
 无向图G为半欧拉图,当且仅当G为连通图且除了两个顶点的度为奇数之外,其它所有顶点的度为偶数。

2.有向图中:
  有向图G为欧拉图,当且仅当G为连通图,且所有顶点的入度等于出度。
  
  有向图G为半欧拉图,当且仅当G为连通图,且存在顶点u的入度比出度大1,v的入度比出度小1,其它所有顶点的入度等于出度。

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值