1126 Eulerian Path (25分)——C语言实现(含测试三错误原因)

1126 Eulerian Path (25分)

In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous Seven Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are called Eulerian. If there are exactly two vertices of odd degree, all Eulerian paths start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is called semi-Eulerian. (Cited from https://en.wikipedia.org/wiki/Eulerian_path)

Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N (≤ 500), and M, which are the total number of vertices, and the number of edges, respectively. Then M lines follow, each describes an edge by giving the two ends of the edge (the vertices are numbered from 1 to N).

Output Specification:

For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph – either Eulerian, Semi-Eulerian, or Non-Eulerian. Note that all the numbers in the first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.

Sample Input 1:

7 12
5 7
1 2
1 3
2 3
2 4
3 4
5 2
7 6
6 3
4 5
6 4
5 6

Sample Output 1:

2 4 4 4 4 4 2
Eulerian

Sample Input 2:

6 10
1 2
1 3
2 3
2 4
3 4
5 2
6 3
4 5
6 4
5 6

Sample Output 2:

2 4 4 4 3 3
Semi-Eulerian

Sample Input 3:

5 8
1 2
2 5
5 4
4 1
1 3
3 2
3 4
5 3

Sample Output 3:

3 3 4 3 3
Non-Eulerian

题目大意及思路:

对于无向图来说,若结点度数都是偶数,则是欧拉图;若结点度数有两个奇数,其余为偶数,则为半欧拉图;其他情况不是欧拉图。

错误:

测试点3通不过的原因是没有判断是否是连通图,可通过DFS判断。

代码:

#include<stdio.h>
#define maxn 510

int G[maxn][maxn]={0};//存储图
int a[maxn]={0};//存储顶点度
int visit[maxn]={0};//用于判断顶点是否访问
int vexnum,arcnum;
int count=0;

int Judge(){
	int t=0;
	for(int i=1;i<=vexnum;i++){
		if(a[i]%2!=0){
			t++;
		}
	}
	return t;
}
void DFS(int v){
	visit[v] = 1;
	count++;
	for(int i = 1; i <= vexnum; i++){
		if(G[v][i] != 0 && !visit[i])
			DFS(i);
	}
}
int main(){
	int i,j;
	scanf("%d %d",&vexnum,&arcnum);
	for(i=1;i<=arcnum;i++){
		int v1,v2;
		scanf("%d %d",&v1,&v2);
		G[v1][v2]=G[v2][v1]=1;
	}
	for(i=1;i<=vexnum;i++){
		for(j=1;j<=vexnum;j++){
			if(G[i][j]!=0){
				a[i]++;
			}
		}
	}
	for(i=1;i<=vexnum;i++){
		printf("%d",a[i]);
		if(i<vexnum)
			printf(" ");
	}
	printf("\n");
	DFS(1);
	if(count==vexnum && Judge()==0)
		printf("Eulerian");
	else if(count==vexnum && Judge()==2)
		printf("Semi-Eulerian");
	else
		printf("Non-Eulerian");
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

21岁被迫秃头

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值