##配置基于 IP 子网划分 VLAN

通过配置基于 IP 子网划分 VLAN,将指定网段或 IP 地址发出的报文在指定的 VLAN中传输,减轻了网络管理者的初始配置任务量,且有利于管理。
在这里插入图片描述
企业拥有多种业务,如 IPTV、VoIP、Internet 等,每种业务使用的 IP 地址各不相同。为了便于管理, 现需要将同一种类型业务划分到同一 VLAN中,不同类型的业务划分到不同 VLAN中。
Switch 接收到用户报文有数据、 IPTV、语音等多种业务,用户设备的 IP 地
址各不相同。现需要将不同类型的业务划分到不同的 VLAN中,通过不同的 VLAN ID 分流到
不同的远端服务器上以实现业务互通。
配置思路
采用如下的思路配置基于 IP 子网划分 VLAN:
创建 VLAN,确定每种业务所属的 VLAN。
关联 IP 子网和 VLAN。
交换机根据报文中的源 IP 地址或指定网段确定 VLAN。新站点在入网时无需进行
太多配置,交换机则根据各站点网络地址自动将其划分到不同的 VLAN中。
允许基于 IP 子网的 VLAN通过当前端口。
配置 VLAN划分方式的优先级,确保优先选择基于 IP 子网划分 VLAN。
使能基于 IP 子网划分 VLAN。
数据准备
为完成此配置例,需准备如下的数据。
配置接口 GE0/0/1 以 untagged 方式加入 VLAN100、VLAN200、VLAN300。
配置接口 GE0/0/2 、GE0/0/3 和 GE0/0/4 以 tagged 方式分别加入 VLAN100、VLAN200
和 VLAN300。
操作步骤
创建 VLAN
在 Switch 上创建 VLAN100、VLAN200 和 VLAN300。
system-view
[Quidway] vlan batch 100 200 300
配置接口
在 Switch 上配置接口 GE0/0/1 为 Hybrid 类型,并加入 VLAN100、VLAN200和
VLAN300。
[Quidway] interface gigabitethernet 0/0/1
[Quidway-GigabitEthernet0/0/1] port link-type hybrid
[Quidway-GigabitEthernet0/0/1] port hybrid untagged vlan 100 200 300
[Quidway-GigabitEthernet0/0/1] quit
在 Switch 上配置接口 GE0/0/2 加入 VLAN100。
[Quidway] interface gigabitethernet 0/0/2
[Quidway-GigabitEthernet0/0/2] port link-type trunk
[Quidway-GigabitEthernet0/0/2] port trunk allow-pass vlan 100
[Quidway-GigabitEthernet0/0/2] quit
在 Switch 上配置接口 GE0/0/3 加入 VLAN200。
[Quidway] interface gigabitethernet 0/0/3
[Quidway-GigabitEthernet0/0/3] port link-type trunk
[Quidway-GigabitEthernet0/0/3] port trunk allow-pass vlan 200
[Quidway-GigabitEthernet0/0/3] quit
在 Switch 上配置接口 GE0/0/4 加入 VLAN300。
[Quidway] interface gigabitethernet 0/0/4
[Quidway-GigabitEthernet0/0/4] port link-type trunk
[Quidway-GigabitEthernet0/0/4] port trunk allow-pass vlan 300
[Quidway-GigabitEthernet0/0/4] quit
在 Switch 上配置接口 GE0/0/1 使能基于 IP 子网划分 VLAN功能。
[Quidway] interface gigabitethernet 0/0/1
[Quidway-GigabitEthernet0/0/1] ip-subnet-vlan enable
[Quidway-GigabitEthernet0/0/1] quit
配置基于 IP 子网划分 VLAN
在 Switch 上配置 VLAN100与 IP 地址 192.168.1.2 关联,优先级为 2。
[Quidway] vlan 100
[Quidway-vlan100] ip-subnet-vlan 1 ip 192.168.1.2 24 priority 2
[Quidway-vlan100] quit
在 Switch 上配置 VLAN200与 IP 地址 192.168.2.2 关联,优先级为 3。
[Quidway] vlan 200
[Quidway-vlan200] ip-subnet-vlan 1 ip 192.168.2.2 24 priority 3
[Quidway-vlan200] quit
在 Switch 上配置 VLAN300与 IP 地址 192.168.3.2 关联,优先级为 4。
[Quidway] vlan 300
[Quidway-vlan300] ip-subnet-vlan 1 ip 192.168.3.2 24 priority 4
[Quidway-vlan300] quit
验证配置结果
在 Switch 上执行以下命令
[Quidway] display ip-subnet-vlan vlan all

已标记关键词 清除标记
相关推荐
©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页