hdu2717:Catch That Cow

Catch That Cow

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14813    Accepted Submission(s): 4476


Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
 

Input
Line 1: Two space-separated integers: N and K
 

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
 

Sample Input
  
  
5 17
 

Sample Output
 
 
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minute


思路:当前所在的点看作根节点,那么可以走的三种路径就是三个儿子。这样就很容易看出这是一个树,bfs

#include<iostream>
#include<cstdio>
#include<string>
#include<map>
#include<algorithm>
#include<string.h>
#include<queue>
#define ll long long
using namespace std;
int n,k;
int v[200005];
int bfs()
{
    int a;
    a=n;
    v[n]=1;
    queue<int>q;
    q.push(a);
    while(!q.empty()){
        a=q.front();
        q.pop();
        if(a==k){
            return v[a];
        }
        if(!v[a-1]&&a-1>=0){
            v[a-1]=v[a]+1;
            q.push(a-1);
        }
        if(!v[a+1]&&a+1<=100000){
            v[a+1]=v[a]+1;
            q.push(a+1);
        }
        if(!v[a*2]&&a*2<=100000){//数组要开大点 v[200005],不然会越界 or a*2放在 !v[a*2]前面
            v[a*2]=v[a]+1;
            q.push(a*2);
        }
    }
    return -1;
}
int main()
{
    while(cin>>n>>k){
        memset(v,0,sizeof(v));
        int ans;
        ans=bfs();
        cout<<ans-1<<endl;
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值