HDU 2717: Catch that cow (BSF)

Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
 

Input
Line 1: Two space-separated integers: N and K
 

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
 

Sample Input
  
  
5 17
 

Sample Output
  
  
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

题意

农夫需要找到他的牛,农夫现在所在位置是N,牛在K点,假设牛是不动的,农夫有三种走法:

  1. 向前走一步(N+1)
  2. 向后走一步(N-1)
  3. 跳到当前位置两倍处(2*N)

问,最少走多少次才能找到他的牛。

解题思路:把所有的情况都列举一遍,最先找到的,就是用次最少的。

具体代码:

#include<cstdio>
#include<cstring>
#include<queue>
const int M=300010;
using namespace std;
struct pon{
    int x,ans;
};
int vis[M],n,k;
int bfs()
{
    pon p,pp;
    memset(vis,0,sizeof(vis));
    queue<pon> q;
    p.ans=0;p.x=n;
    q.push(p);
    vis[p.x]=1;
    while(!q.empty())
    {
        p=q.front();
        q.pop();
        if(p.x==k)
        {
            return p.ans;
        }
        if(p.x+1<M&&!vis[p.x+1])
        {
            pp.x=p.x+1;
            pp.ans=p.ans+1;
            q.push(pp);
            vis[p.x]=1;
        }
        if(p.x-1>=0&&p.x-1<M&&!vis[p.x-1])
        {
            pp.x=p.x-1;pp.ans=p.ans+1;
            q.push(pp);
            vis[p.x]=1;
        }
        if(p.x*2<M&&!vis[p.x*2])
        {
            pp.x=p.x*2;pp.ans=p.ans+1;
            q.push(pp);
            vis[p.x]=1;
        }
    }
}
int main()
{
    int ans;
    while(scanf("%d %d",&n,&k)!=EOF)
    {
        ans=bfs();
        printf("%d\n",ans);


    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值