Radar Installation

Radar Installation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 86867 Accepted: 19450

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1


思路:

很容易就看出这是一道贪心题,不过需要思考的是怎样去转化一下可以轻松实现出来,以岛屿为圆心,以雷达的半径为半径画圆,截得的数轴的线段就是雷达要覆盖该岛可以放的位置,这样就成了线段求贪心了,求有几段不重叠的线段就可以了。注意:精度!!

#include<iostream>
#include<math.h>
#include<algorithm>
using namespace std;
struct point
{
    double r,l;
};
bool cmp(const struct point a,const struct point b)
{
    return a.l<b.l;
}
int main()
{
    int n,d;
    int j=0;
    while(cin>>n>>d&&(n||d)){
        point p[1005];
        int f=1;
        for(int i=0;i<n;i++){
            int a,b;
            cin>>a>>b;
            if(b>d)f=0;
            double an=sqrt(d*d*1.0-b*b*1.0);
            p[i].r=a*1.0-an;//左端点,
            p[i].l=a*1.0+an;//右端点,单词弄错了,只好将错就错了。敲打
        }
        sort(p,p+n,cmp);
        int ans=0;
        double ls;
        for(int i=0;i<n;i++){
            if(i==0){
                ls=p[i].l;
                ans++;
            }
            else{
                if(p[i].r>ls){
                    ls=p[i].l;
                    ans++;
                }
            }
        }
        j++;
        if(f==1)cout<<"Case "<<j<<": "<<ans<<endl;
        else cout<<"Case "<<j<<": "<<"-1"<<endl;
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值