第七届福建省大学生程序设计竞赛 Problem J- X(floyd)

 Problem Description

X is a fully prosperous country, especially known for its complicated transportation networks. But recently, for the sake of better controlling by the government, the president Fat Brother thinks it’s time to close some roads in order to make the transportation system more effective.

Country X has N cities, the cities are connected by some undirected roads and it’s possible to travel from one city to any other city by these roads. Now the president Fat Brother wants to know that how many roads can be closed at most such that the distance between any two cities in country X does not change. Note that the distance between city A and city B is the minimum total length of the roads you need to travel from A to B.

技术分享 Input

The first line of the date is an integer T (1 <= T <= 50), which is the number of the text cases.

Then T cases follow, each case starts with two numbers N, M (1 <= N <= 100, 1 <= M <= 40000) which describe the number of the cities and the number of the roads in country X. Each case goes with M lines, each line consists of three integers x, y, s (1 <= x, y <= N, 1 <= s <= 10, x is not equal to y), which means that there is a road between city x and city y and the length of it is s. Note that there may be more than one roads between two cities.

技术分享 Output

For each case, output the case number first, then output the number of the roads that could be closed. This number should be as large as possible.

See the sample input and output for more details.

技术分享 Sample Input

2 2 3 1 2 1 1 2 1 1 2 2 3 3 1 2 1 2 3 1 1 3 1

技术分享 Sample Output

Case 1: 2 Case 2: 0

 

用exist数组记录i,j之间是否有直接连接的边。用an表示最终答案,初始读入数据时,如果i\j之间已经存在边了,则an++(因为i\j间最终一定只保留一条边)。

除此之外,只需判断存在i\j之间存在的直达边能不能被其他的一系列边替代(这里只要距离<=直达边的距离就可以替代)。只需要在floyd过程中增加一个标记的数组来记录即可。

直接上floyd,松弛的时候判断即可,注意用本身松弛的情况,一个简单的方法是,初始化图时不用把[i][i]这种点变为0,直接inf就行

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
const int inf=0x3f3f3f3f;
const int N=105;
int e[N][N];
int book[N][N],vis[N][N];
int n,m,ans;
void floyd()
{
    for(int k=1; k<=n; k++)
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
                if(e[i][j]>=e[i][k]+e[k][j])//>=可以松弛,则原本的e[i][j]这条边可以删去
                {
                    e[i][j]=e[i][k]+e[k][j];
                    book[i][j]=1;
                }
}
int main()
{
    int t,q=1,u,v,w;
    scanf("%d",&t);
    while(t--)
    {
        ans=0;
        mem(book,0);
        mem(vis,0);
        scanf("%d%d",&n,&m);
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
                e[i][j]=inf;
        for(int i=0; i<m; i++)
        {
            scanf("%d%d%d",&u,&v,&w);
            vis[u][v]=vis[v][u]=1;
            if(e[u][v]!=inf)
            ans++;
            e[u][v]=e[v][u]=min(e[u][v],w);
        }
        floyd();
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
                if(vis[i][j])
                {
                    vis[i][j]=vis[j][i]=0;
                    if(book[i][j])
                        ans++;
                }
        printf("Case %d: %d\n",q++,ans);
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值