FZU 2271 X (Floyd)(第七届福建省大学生程序设计竞赛)

68 篇文章 0 订阅
34 篇文章 0 订阅

X

Problem Description
X is a fully prosperous country, especially known for its complicated transportation networks. But recently, for the sake of better controlling by the government, the president Fat Brother thinks it’s time to close some roads in order to make the transportation system more effective.

Country X has N cities, the cities are connected by some undirected roads and it’s possible to travel from one city to any other city by these roads. Now the president Fat Brother wants to know that how many roads can be closed at most such that the distance between any two cities in country X does not change. Note that the distance between city A and city B is the minimum total length of the roads you need to travel from A to B.

Input
The first line of the date is an integer T (1 <= T <= 50), which is the number of the text cases.

Then T cases follow, each case starts with two numbers N, M (1 <= N <= 100, 1 <= M <= 40000) which describe the number of the cities and the number of the roads in country X. Each case goes with M lines, each line consists of three integers x, y, s (1 <= x, y <= N, 1 <= s <= 10, x is not equal to y), which means that there is a road between city x and city y and the length of it is s. Note that there may be more than one roads between two cities.

Output
For each case, output the case number first, then output the number of the roads that could be closed. This number should be as large as possible.

See the sample input and output for more details.

Sample Input
2
2 3
1 2 1
1 2 1
1 2 2
3 3 1 2 1 2 3 1 1 3 1 Sample Output
Case 1: 2
Case 2: 0

思路:
一遍floyd找出最短路径并记录下被松弛的边,再来一遍floyd找出被松弛的边即可(重边可以先预处理掉)

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

const int inf=0x3f3f3f3f;
const int maxn=100+10;
int mp[maxn][maxn],mmp[maxn][maxn],vis[maxn][maxn];
int n,m;

void Floyd()
{
    for(int k=1; k<=n; ++k)
        for(int i=1; i<=n; ++i)
            for(int j=1; j<=n; ++j)
            {
                if(i==j)
                    continue;
                if(mp[i][k]<inf&&mp[k][j]<inf&&mp[i][j]>=mp[i][k]+mp[k][j])
                    mp[i][j]=mp[i][k]+mp[k][j],vis[i][j]=1;
            }
}

int main()
{
    int t,res=0;
    scanf("%d",&t);
    while(++res<=t)
    {
        memset(vis,0,sizeof(vis));
        memset(mp,inf,sizeof(mp));
        scanf("%d%d",&n,&m);
        int u,v,w,ans=0;
        for(int i=1; i<=m; ++i)
        {
            scanf("%d%d%d",&u,&v,&w);
            if(mp[u][v]<inf)//先剪去重边
                ++ans;
            mp[u][v]=mp[v][u]=min(w,mp[u][v]);
        }
        memcpy(mmp,mp,sizeof(mmp));
        Floyd();
        for(int i=1; i<=n; ++i)
            for(int j=1; j<i; ++j)
            {
                if(mmp[i][j]==inf)
                    continue;
                if((mp[i][j]<=mmp[i][j]&&vis[i][j]))//表示i到j这条边可以被松弛,剪去
                    ++ans;
            }
        printf("Case %d: %d\n",res,ans);
    }
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值