04-树5 Root of AVL Tree (25分)

04-树5 Root of AVL Tree   (25分)

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer NN (\le 2020) which is the total number of keys to be inserted. Then NN distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:

5
88 70 61 96 120

Sample Output 1:

70

Sample Input 2:

7
88 70 61 96 120 90 65

Sample Output 2:

88


就是构造一棵平衡二叉树,输出它的根节点数据。

#include<iostream>
#include<cstdlib>
using namespace std;
typedef struct AVLTreenode *AVLTree;
struct AVLTreenode
{
	int height;
	int data;
	AVLTree lchild;
	AVLTree rchild;
};
int Getheight(AVLTree T)
{
	int LH,RH,MaxH;
	if(T)
	{
		LH=Getheight(T->lchild);
		RH=Getheight(T->rchild);
		MaxH=LH>RH?LH:RH;
		return MaxH+1;
	}
	else
		return 0;
}
AVLTree SingleLeftRotation(AVLTree A)
{
	AVLTree B=A->lchild;
	A->lchild=B->rchild;
	B->rchild=A;
	A->height=max(Getheight(A->lchild),Getheight(A->rchild))+1;
	B->height=max(Getheight(B->lchild),Getheight(B->rchild))+1;
	return B;
}
AVLTree SingleRightRotation(AVLTree A)
{
	AVLTree B=A->rchild;
	A->rchild=B->lchild;
	B->lchild=A;
	A->height=max(Getheight(A->lchild),Getheight(A->rchild))+1;
	B->height=max(Getheight(B->lchild),Getheight(B->rchild))+1;
	return B;
}
AVLTree DoubleLeftRightRotation(AVLTree A)
{
	A->lchild=SingleRightRotation(A->lchild);
	return SingleLeftRotation(A);
}
AVLTree DoubleRightLeftRotation(AVLTree A)
{
	A->rchild=SingleLeftRotation(A->rchild);
	return SingleRightRotation(A);
}
AVLTree Insert(int x,AVLTree T)
{
	if(!T)
	{
		T=(AVLTree)malloc(sizeof(struct AVLTreenode));
		T->data=x;
		T->height=0;
		T->lchild=T->rchild=NULL;
	}
	else if(x<T->data)
	{
		T->lchild=Insert(x,T->lchild);
		if(Getheight(T->lchild)-Getheight(T->rchild)==2)
		{
			if(x<T->lchild->data)
			{
				T=SingleLeftRotation(T);
			}
			else
			{
				T=DoubleLeftRightRotation(T);
			}
		}
	}
	else
		if(x>T->data)
		{
			T->rchild=Insert(x,T->rchild);
			if(Getheight(T->lchild)-Getheight(T->rchild)==-2)
			{
				if(x>T->rchild->data)
				{
					T=SingleRightRotation(T);
				}
				else
				{
					T=DoubleRightLeftRotation(T);
				}
			}
		}
		T->height=max(Getheight(T->lchild),Getheight(T->rchild))+1;
		return T;
}
int main()
{
	int n;
	AVLTree T=NULL;
	cin>>n;
	for(int i=0;i<n;i++)
	{
		int temp;
		cin>>temp;
		T=Insert(temp,T);
	}
	cout<<T->data<<endl;
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

没想好叫什么名字

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值