题目链接:https://pintia.cn/problem-sets/994805342720868352/problems/994805462535356416
Given any string of N (≥5) characters, you are asked to form the characters into the shape of U
. For example, helloworld
can be printed as:
h d
e l
l r
lowo
That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U
to be as squared as possible -- that is, it must be satisfied that n1=n3=max { k | k≤n2 for all 3≤n2≤N } with n1+n2+n3−2=N.
Input Specification:
Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.
Output Specification:
For each test case, print the input string in the shape of U as specified in the description.
Sample Input:
helloworld!
Sample Output:
h !
e d
l l
lowor
:题意
- n1=n3
- n2>=n1
- n1 尽可能大
所以n1和n3取(len/3),n2=len-n1-n3+2
#include<iostream>
#include<cstring>
using namespace std;
int main(){
char s[100];
cin>>s;
int len=strlen(s);
int n1=(len+2)/3;
int n2=len-2*n1+2;
for(int i=0;i<n1-1;i++){
cout<<s[i];
for(int j=0;j<n2-2;j++){
cout<<" ";
}
cout<<s[len-1-i]<<endl;
}
for(int i=0;i<n2;i++){
cout<<s[n1-1+i];
}
return 0;
}