PAT (Advanced Level) Practice — 1065 A+B and C (64bit) (20 分)

题目链接:https://pintia.cn/problem-sets/994805342720868352/problems/994805406352654336

Given three integers A, B and C in [−2​63​​,2​63​​], you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, Band C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false

:思路  溢出的两种情况:两个正数相加,两个负数相加的溢出

①正数相加向上溢出最后得到的是一个负数,显然a+b>c,因为c的最大值是2^63, a+b溢出,显然是超过这个最大值了
②如果是负数相加向下溢出,得到的是正值,显然a+b<c,因为超出c的最小值了。

#include<iostream>
using namespace std;
int main(){
	int n;
	long long a,b,c;
	while(cin>>n){
		for(int i=0;i<n;i++){
			bool f=0;
			cin>>a>>b>>c;
			long long ans=a+b;
			if(a>0&&b>0&&ans<=0){
				f=1;
			}else if(a<0&&b<0&&ans>=0){
				f=0;
			}else if(ans>c){
				f=1;
			}
			if(f){
				printf("Case #%d: true\n",i+1);
			}else{
				printf("Case #%d: false\n",i+1);
			}
		}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值