PAT (Advanced Level) Practice 1065 A+B and C (64bit) (20 分) 凌宸1642

PAT (Advanced Level) Practice 1065 A+B and C (64bit) (20 分) 凌宸1642

题目描述:

Given three integers A, B and C in [−263 , 263], you are supposed to tell whether A + B > C.

译:给定三个整数 A , B , C 在区间 [ −263 , 263 ] , 你应该说明 是否 A + B > C.


Input Specification (输入说明):

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

译:第一行输入正整数 T (≤10) 代表测试样例的数量。 然后,紧跟着 T 个测试用例,每个用例占一行,包含 3 个用单个空格隔开的整数 A, B 和 C 。


Output Specification (输出说明):

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

译:对于每个测试用例,如果 A+B>C 你应该在一行中输出 Case #X: true ,否则输出 Case #X: false , 其中 X 表示第几个测试(从 1开始 ) .


Sample Input (样例输入):

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output (样例输出):

Case #1: false
Case #2: true
Case #3: false

The Idea:

之前在 PAT-B 1011 里面写过类似的题,当时的 范围是 [−231 , 231],采用 long long 完全足够。但是现在变成了[−263 , 263] , 所以采用long long 是会有溢出的 。其实也很简单,采用 long double 数据类型就可以解决啦

The Codes:

#include<iostream>
using namespace std ;
typedef long double ld ;
int main(){
	int t ;
	cin >> t ;
	for(int i = 1; i <= t ; i ++){
		ld a , b , c ;
		cin>> a >> b >> c ;
		cout<< "Case #"<< i <<": "<<((a> (c - b))?"true":"false")<<endl ;
	}
	return 0 ;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

lingchen0522

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值