山东省第六届ACM省赛 F BIGZHUGOD and His Friends II

BIGZHUGOD and His Friends II

Time Limit: 1000 ms  Memory Limit: 65536 KiB
Problem Description

BIGZHUGOD and his three friends are playing a game in a triangle ground.

The number of BIGZHUGOD is 0, and his three friends are numbered from 1 to 3. Before the game begins, three friends stand on three vertices of triangle in numerical order (1 on A, 2 on B, 3 on C), BIGZHUGOD stands inside of triangle.

Then the game begins, three friends run to the next vertex in uniform speed and in straight direction (1 to B, 2 to C, 3 to A and there speeds may different). And BIGZHUGOD can stand in any position inside the triangle.

When any of his friends arrives at next vertex, the game ends.

BIGZHUGOD and his friends have made an agreement: we assume that the beginning is time 0, if during the game, you can find a moment that BIGZHUGOD can block the sight line of 1 to C, 2 to A, 3 to B. Then each friend has to treat BIGZHUGOD with a big meal.

Now BIGZHUGOD knows the lengths of time that his three friends need run to next vertices t1, t2 and t3. He wants to know whether he has a chance to gain three big meals, of course he wants to know in which exciting moment t, he can block three friends\' sight line.

Input

The first line contains an integer T, indicating the number of test cases (T ≤ 1000).

For each case there are three integer t1, t2, t3 (1 ≤ t1, t2, t3 ≤ 100).

Output

If BIGZHUGOD has a chance to gain big meal from his friends, output "YES" and the exciting moment t rounding to 4 digits after decimal point. Otherwise, output "NO".

Sample Input
2 
1 1 1 
3 4 6
Sample Output
YES 0.5000 
YES 2.0000
Hint
Source

“浪潮杯”山东省第六届ACM大学生程序设计竞赛

题解:塞瓦定理。浮点二分枚举答案

#include<bits/stdc++.h>
#define esp 1e-6
using namespace std;

double t1,t2,t3;
int main()
{
    int caset;scanf("%d",&caset);
    while(caset--) {
        scanf("%lf%lf%lf",&t1,&t2,&t3);

        double l = 0.0,r = min(t1,min(t2,t3));
        bool flag = false;
        double mid,temp;
        for(int i = 0;i<100;i++) {
            mid = (l+r)*0.5;
            temp = mid * mid * mid - (t1-mid) * (t2-mid) * (t3-mid);
            if(temp < 0) l = mid;
            else r = mid;
        }
        //fabs(temp) < esp
        printf("YES %.4f\n",mid);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值