Balanced Number
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 7941 Accepted Submission(s): 3789
Problem Description
A balanced number is a non-negative integer that can be balanced if a pivot is placed at some digit. More specifically, imagine each digit as a box with weight indicated by the digit. When a pivot is placed at some digit of the number, the distance from a digit to the pivot is the offset between it and the pivot. Then the torques of left part and right part can be calculated. It is balanced if they are the same. A balanced number must be balanced with the pivot at some of its digits. For example, 4139 is a balanced number with pivot fixed at 3. The torqueses are 4*2 + 1*1 = 9 and 9*1 = 9, for left part and right part, respectively. It's your job
to calculate the number of balanced numbers in a given range [x, y].
Input
The input contains multiple test cases. The first line is the total number of cases T (0 < T ≤ 30). For each case, there are two integers separated by a space in a line, x and y. (0 ≤ x ≤ y ≤ 1018).
Output
For each case, print the number of balanced numbers in the range [x, y] in a line.
Sample Input
2
0 9
7604 24324
Sample Output
10
897
解析:
明明是一道简单的数位DP,我却因为一些低级错误卡了一个小时。。。
令表示到第 i 位,和为 sum ,有无限制,支点在 d 的数量。
注意!!
答案要去掉重复的0!!!(因为支点在每一位都有0满足情况)
sptinf只能由int转char!!!
代码:
#include <bits/stdc++.h>
#define int long long
using namespace std;
const int Max=20;
int t,n,m,l,r,sum;
int f[Max][1505][2][Max];
int ch[Max];
inline int dfs(int pos,int sum,int limit,int d)
{
if(pos==n+1) {return !sum ? 1 : 0;}
if(~f[pos][sum][limit][d]) return f[pos][sum][limit][d];
int mx=limit?ch[pos]:9,ans=0;
for(int i=0;i<=mx;i++) ans+=dfs(pos+1,sum+(n-pos+1-d)*i,limit&(i==mx),d);
return f[pos][sum][limit][d]=ans;
}
inline int solve(int num)
{
if(num==-1) return 0;
sum=n=0;
while(num){ch[++n]=num%10,num/=10;}
reverse(ch+1,ch+n+1);
memset(f,-1,sizeof(f));
for(int i=1;i<=n;i++) sum+=dfs(1,0,1,i);
sum-=n-1;
return sum;
}
signed main()
{
cin>>t;
while(t--)
{
cin>>l>>r;
cout<<solve(r)-solve(l-1)<<"\n";
}
return 0;
}