1024 Palindromic Number (25 分)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (≤10​10​​) is the initial numer and K (≤100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3

思路:

就是判断是否为回文字符串,若不是则 将其逆置再相加,直到保证是回文数字,前提是要给定在一定的次数限制之内,本题的关键在于不能直接相加,这样会超出long int 应该使用string直接相加。

 

#include<iostream>
#include<string>
#include<stdio.h>
#include<string.h>
#include<vector>
#include<set>
#include<map>
#include<unordered_map>
#include<queue>
#include<algorithm>
#include<cmath>
using namespace std;
#define ll long long
#define vi vector<int>
#define pii pair<int, int>
#define x first
#define y second
string s,tmp; int k;
void add(string t)
{
    int len=s.length(),carry=0;
    for(int i=0;i<len;i++)
    {
        s[i]=s[i]+t[i]+carry-'0';// s 和 t 对应的i位相加,并且加上进位
        carry=0;                 //进位置为0
        if(s[i]>'9')             //如果相加后的结果>‘9’则将该位 -10 并且进位加1
        {
            s[i]=s[i]-10;
            carry=1;
        }
    }
    if(carry) s+='1';           //如果最后一位有进位,则加1 
    reverse(s.begin(),s.end()); // 计算的时 ,从0--n 存储(最低位在最左边),因此需要反转一下。
}
bool ispal(string s)
{
    string temp= s;
    reverse(temp.begin(),temp.end());
    if(temp==s) return true;
    else return false;
}
int main()
{
    cin>>s>>k;
    int cnt=0;
    while(!ispal(s)&&cnt<k)
    {
        cnt++;
        string t=s;
        reverse(t.begin(),t.end());
        add(t);
    }
    if(cnt==0)
    {
       cout<<s<<endl;
       cout<<0<<endl;
    }
    else{
       cout<<s<<endl;
       cout<<cnt<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值