【C++编程基础】AOJ (C++ Programming II)—1-B-deque

1-B-deque

题目

deque
For a dynamic array A={a0,a1,…} of integers, perform a sequence of the following operations:
  • 0 push(d, x): Add element x at the begining of A, if d=0. Add element x at the end of A, if d=1.
  • 1 randomAccess§: Print element ap.
  • 2 pop(d): Delete the first element of A, if d=0. Delete the last element of A, if d=1. A is a 0-origin array and it is empty in the initial state.
输入
The input is given in the following format.
q
query1
query2
:
queryq
Each query queryi is given by 0 d x , or 1 p, or 2 d ,where the first digits 0, 1 and 2 represent push, randomAccess and pop operations respectively. randomAccess and pop operations will not be given for an empty array. 1≤q≤400,000 0≤p< the size of A −1,000,000,000≤x≤1,000,000,000
输出
For each randomAccess, print ap in a line.

样例输入

11
0 0 1
0 0 2
0 1 3
1 0
1 1
1 2
2 0
2 1
0 0 4
1 0
1 1

样例输出

2
1
3
4
1

题解(代码流程)

#include<bits/stdc++.h>

using namespace std;
#define  endl '\n'

int main() {
    ios::sync_with_stdio(false);
    cin.tie(nullptr);
    cout.tie(nullptr);
    deque<int> A;//定义双端队列A
    int q;
    cin >> q;
    while (q--) {
        int t;
        cin >> t;
        if (t == 0) {
            int d, x;
            cin >> d >> x;
            if (d == 0)A.push_front(x);//在头部加入一个元素
            else if (d == 1)A.push_back(x);//在尾部加入一个元素
        } else if (t == 1) {
            int p;
            cin >> p;
            if (A.empty())continue;
            cout << A[p] << endl;//
        } else {
            int d;
            cin >> d;
            if (A.empty())continue;
            if (d == 0)A.pop_front();//删除头部一个元素
            else if (d == 1)A.pop_back();//删除尾部一个元素
        }
    }

    return 0;
}

小结

学习了deque的定义与使用,及几项对deque修改的基本操作。
remember
  • push_back()
  • push_front()
  • pop_back()
  • pop_front()
  • begin():返回指向第一个元素的迭代器
  • rbegin():返回指向尾部的逆向迭代器
  • end():返回指向尾部的迭代器
  • rend():返回指向头部的逆向迭代器
  • empty()
  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值