9476:Deque(双端队列)

题目描述

For a dynamic array A={a0,a1,...}of integers, perform a sequence of the following operations:
push(d, x): Add element x at the begining of A, if d=0. Add element x at the end of A, if d=1.
randomAccess(p): Print element ap.
pop(d): Delete the first element of A, if d=0. Delete the last element of A, if d=1.
A is a 0-origin array and it is empty in the initial state.

输入

The input is given in the following format.
q
query1
query2
:
queryq
Each query queryi is given by

0 d x
or

1 p
or

2 d
where the first digits 0, 1 and 2 represent push, randomAccess and pop operations respectively.

randomAccess and pop operations will not be given for an empty array.

输出

For each randomAccess, print ap in a line.

样例输入 Copy

11
0 0 1
0 0 2
0 1 3
1 0
1 1
1 2
2 0
2 1
0 0 4
1 0
1 1

样例输出 Copy

2
1
3
4
1

提示

1≤q≤400,000
0≤p<0≤p< the size of A
−1,000,000,000≤x≤1,000,000,000

代码

#include <bits/stdc++.h>
#include <deque>
using namespace std;
int main()
{
    int n;
    deque<int> d;         //双端队列
    cin>>n;
    while(n--)
    {
        int a,b,c;
        scanf("%d",&a);
        if(a==0){
            scanf("%d%d",&b,&c);
            if(b) d.push_back(c);       //队尾入队
            else d.push_front(c);       //队头入队
        }
        if(a==1){
                scanf("%d",&b);
            cout<<d[b]<<'\n';       //双端队列可直接下标访问
        }
        if(a==2){
            scanf("%d",&b);
            if(!b) d.pop_front();      //队头出队
            else d.pop_back();        //队尾出队
        }
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值