寒假集训_专题一题解_A(POJ 3061)

题目

Time Limit: 1000MS Memory Limit: 65536K
Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.
Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.
Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input
2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output
2
3

题目大意

给你一段由正整数的序列,和一个正整数S,让你再此序列中找到最小的连续子序列(包括自身),使得子序列序列个数最小,且子序列的和大于等于S。

题目分析

典型的双指针(尺取)算法,设置两个指针i、j,计算i为起点,j为终点的子序列的和sum,并检验。不难得出,若sum>=S,则更新答案,并且i加到sum<S时。若sum<S,则j加到sum>=S。

代码

#include <iostream>
using namespace std;
int a[100010];
int main()
{
	int t;
	cin >> t;
	while(t--)
	{
		int n,s,ts = 0,ans = 0x3f3f3f3f;
		scanf("%d%d", &n, &s);
		for(int i = 1; i <= n; i ++)
		scanf("%d",&a[i]);
		ts = a[1];
		for(int i = 1, j = 1;;)
		{
			if(ts >= s)
			{
				ans = min(ans, j - i + 1);
				ts -= a[i];
				i ++;
			}
			else if(j < n)
			{
				j ++;
				ts += a[j];
			}
			else break;
		}
		if(ans != 0x3f3f3f3f)printf("%d\n",ans);
		else printf("0\n");
	}
	return 0;
 } 

注意点

1.无解的情况
2.指针i,j不能越界

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值