寒假集训_专题一题解_F - BFS (POJ - 1426)

题目

Find The Multiple
Time Limit: 1000MS Memory Limit: 10000K
Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input

2
6
19
0
Sample Output

10
100100100100100100
111111111111111111

题目大意

给一个数n,求一个由01组成的十进制数,这个数能被n整除

解析

1.本题很坑,答案不会过long long
2.bfs时,可状态压缩

代码

#include<iostream>
#include <cstring>
using namespace std;
bool st[300];
long long cnt,n,ans;
bool check(long long x)
{
	int t = 1, res = 0;
	while(x)
	{
		if(x&1)res = (res + t) % n;
		t = t*10 % n;
		x >>= 1;
	}
	if(res % n ==0)return true;
	return false;
}
int main()
{
	while(scanf("%lld", &n) && n)
	{
		for(long long i = 1;i < 1 << 20;i++)
		{ 
			long long t = i, tmp = 1, res = 0;
			while(t)
			{
				if(t&1)res+=tmp;
				t >>= 1;
				tmp *= 10;
			} 
			if(res%n == 0)
			{
				ans = res;
				break;
			}
		} 
		cnt = 0;
		printf("%lld\n",ans);
	}
	return 0;
 } 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值