寒假集训_专题一题解_B(POJ - 2386)

题目

								Lake Counting
			 	Time Limit: 1000MS		Memory Limit: 65536K
								Description

Due to recent rains, water has pooled in various places in Farmer John’s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W’) or dry land (’.’). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John’s field, determine how many ponds he has.
Input

  • Line 1: Two space-separated integers: N and M

  • Lines 2…N+1: M characters per line representing one row of Farmer John’s field. Each character is either ‘W’ or ‘.’. The characters do not have spaces between them.
    Output

  • Line 1: The number of ponds in Farmer John’s field.
    Sample Input

10 12
W…WW.
.WWW…WWW
…WW…WW.
…WW.
…W…
…W…W…
.W.W…WW.
W.W.W…W.
.W.W…W.
…W…W.
Sample Output

3

题目大意

在n×m的网格中每个点时一个湖泊或者陆地,两个湖泊相连为它们相邻(包括斜的方向),问多少组连通的湖泊。

题目分析

对于每个湖泊bfs,bfs一次cnt++

代码

#include <iostream> 

using namespace std;
bool a[110][110];
int dy[8] = {-1,0,1,-1,1,-1,0,1},dx[8]={-1,-1,-1,0,0,1,1,1}, cnt = 0,n,m;
char op[110];
void dfs(int x,int y)
{
	a[x][y] = false;
	for(int i = 0; i < 8; i ++)
	if(x + dx[i] < n && x+dx[i] >= 0 && y + dy[i] < m && y+dy[i] >= 0 && a[x+dx[i]][y+dy[i]])
		dfs(x+dx[i],y+dy[i]);
}
int main()
{
	cin >> n >> m;
	for(int i = 0; i < n; i ++)
	{
		scanf("%s",op);
		for(int j = 0; j < m; j ++)
		if(op[j] == 'W')a[i][j] = true;		
	}
	for(int i = 0; i < n; i ++)
		for(int j = 0; j< m; j++)
		if(a[i][j])
		{
			dfs(i,j);
			cnt ++;
		}
	cout << cnt;
	return 0;
}

注意点

bfs时x,y要在规定范围内

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值