ayit2020609 第一次月赛i题

In a party held by CocaCola company, several students stand in a circle and play a game.

One of them is selected as the first, and should say the number 1. Then they continue to count number from 1 one by one (clockwise). The game is interesting in that, once someone counts a number which is a multiple of 7 (e.g. 7, 14, 28, ...) or contains the digit '7' (e.g. 7, 17, 27, ...), he shall say "CocaCola" instead of the number itself.

For example, 4 students play this game. At some time, the first one says 25, then the second should say 26. The third should say "CocaCola" because 27 contains the digit '7'. The fourth one should say "CocaCola" too, because 28 is a multiple of 7. Then the first one says 29, and the game goes on. When someone makes a mistake, the game ends.

During a game, you may hear a consecutive of p "CocaCola"s. So what is the minimum number that can make this situation happen?

For example p = 2, that means there are a consecutive of 2 "CocaCola"s. This situation happens in 27-28 as stated above. 27 is then the minimum number to make this situation happen.

Input

Standard input will contain multiple test cases. The first line of the input is a single integer T (1 <= T <= 100) which is the number of test cases. And it will be followed by T consecutive test cases.

There is only one line for each case. The line contains only one integer p (1 <= p <= 99).

Output

Results should be directed to standard output. The output of each test case should be a single integer in one line, which is the minimum possible number for the first of the p "CocaCola"s stands for.

Sample Input

 

2
2
3

 

Sample Output

 

27
70
#include <stdio.h>
#include <string.h>
int a[1000];
int ee(int n)
{
    if(n%7 == 0)
    return 1;
    while(n)
    {
        int r ;
		r=n%10;
        n=n/10;
        if(r == 7)
        return 1;
    }
    return 0;
}
int main()
{
    int t,n,aa,i,j;
     for(i=1;i<=800;i++)
    {
        if(ee(i))
        a[i] = 1;
        else
        a[i] = 0;
    }
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(i=7;i<=800;i++)
        {
            for(j=i;j<i+n;j++)
            {
                if(!a[j])
                break;
            }
            if(j>=i+n)
            {
                aa = i;
                break;
            }
        }
        printf("%d\n",aa);
    }
    
    return 0;
}

总结   题意

寻找满足任意条件之一的数字:

1能够被7整除。

2某一位数是7。

第一行:测试样例的数目N。

借下的N行:每行输入一个数字P求有P个连续的这样的数字中最小的数字。

因为题中说了p较小最大才99

应该找出每个连续的一段满足要求的数把它存起来(用一个数组)

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值