《算法笔记》PTA A1025

1025 PAT Ranking (25 分)

  Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

  Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

  For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85
Sample Output:
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

我的代码

#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
struct Student{
    char id[15];        // 准考证号
    int score;          // 分数
    int local_number;   // 考场号
    int local_rank;     // 考场内排名
}stu[30010];

bool cmp(Student a,Student b){
    if(a.score!=b.score) return a.score>b.score;    // 先按分数从高到低排序
    else return strcmp(a.id,b.id)<0;                // 分数相同按准考证号从小到大排序
}

int main(){
    int n,k,num=0;                // num为考生总数
    if(scanf("%d",&n)){};         // n为考场数
    for(int i=1;i<=n;i++){
        if(scanf("%d",&k)){};     // 该考场内人数
        for(int j=0;j<k;j++){
            if(scanf("%s %d",stu[num].id,&stu[num].score)){};
            stu[num].local_number=i;        // 该考生的考场号为 i
            num++;                          // 总考生数加 1
        }
        sort(stu+num-k,stu+num,cmp);        // 将该考场的考生排序
        stu[num-k].local_rank=1;            // 将该考场第一名的local_rank记为 1
        for(int j=num-k+1;j<num;j++){       // 对该考场剩余的考生
            if(stu[j].score==stu[j-1].score)// 若与前一位考生同分,则local_rank也相同
                stu[j].local_rank=stu[j-1].local_rank;
            else                            // 若与前一位考生不同分,local_rank为该考生前面的人数
                stu[j].local_rank=j+1-(num-k);
        }
    }
    printf("%d\n",num);                     // 输出考生总人数
    sort(stu,stu+num,cmp);                  // 将所有考生排序
    int r=1;                                // 当前考生的排名
    for(int i=0;i<num;i++){
        if(i>0&&stu[i].score!=stu[i-1].score) 
            r=i+1;                         // 当前考生与上一个考生分数不同时,让 r 更新为人数加一
        printf("%s %d %d %d\n",stu[i].id,r,stu[i].local_number,stu[i].local_rank);
    } 
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值