Max Sum Plus Plus

DP

Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems.Now you are faced with a more difficult problem.
Given a consecutive number sequence S1, S2, S3, S4 ... Sx, ... Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767).  We define a function sum(i, j) = Si + ... + Sj (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make 
sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + ... + sum(im, jm) maximal (ix ≤ iy ≤ jx or ix ≤ jy ≤ jx is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. ^_^

Input
Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 ... Sn.
Process to the end of file.

Output
Output the maximal summation described above in one line.

Sample Input
1 3 1 2 3
2 6 -1 4 -2 3 -2 3

Sample Output
6
8


  
Hint
Huge input, scanf and dynamic programming is recommended.

大概题意

有一个长度为m的数组把这个数组分为n段每一段都不相交问这m段之和的最大值

解题思路

f[i][j]表示前j个数分成i组
状态转移方程f[i][j] = max(f[i][j - 1] + max(dp[i-1][k])+a[j]) (0<k<j)
max( dp[i-1][k] ) 就是上一组 0....j-1 的最大值
可以在每次计算dp[i][j]的时候记录下前j个的最大值 用数组保存下来 

闫式dp分析法
在这里插入图片描述
代码

#include <algorithm>
#include <iostream>
#include <cstring>

using namespace std;

int n, m, maxx;
const int N = 1e6 + 10;
const int INF = 0x7fffffff;
int Max[N], dp[N], a[N];

int main()
{
    while (scanf("%d%d",&m,&n) != EOF)
    {
        for (int i = 1; i <= n; i ++ ) scanf("%d",&a[i]);
        memset(dp, 0, sizeof dp);
        memset(Max, 0, sizeof Max);
        for (int i = 1; i <= m; i ++ )
        {
            maxx = -INF;
            for (int j = i; j <= n; j ++ )
            {
                dp[j] = max(dp[j - 1] + a[j], Max[j - 1] + a[j]);
                Max[j - 1] = maxx;
                maxx = max(maxx, dp[j]);
            }
        }
        printf("%d\n", maxx);
    }

    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值