【PAT】【树的已知二序求具体树问题】1020 Tree Traversals (25 分)

题目链接:1020 Tree Traversals (25 分)

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

// raw word:
// postorder后序    inorder中序

// 题目大意:给出后序遍历和中序遍历,求层序遍历

// 解题思路:
// 根据后序遍历找到每个子树根节点,中序遍历区分左右子树,递归求解即可
// 得到具体树后层序遍历输出即可,这里用的队列实现

#include <iostream>
#include <cstdio>
#include <queue>
using namespace std;

const int maxn = 35;
int n;
int post[maxn], in[maxn], mp[maxn][2];

// 注意,要记录两个序列的端点,只记录一个序列的两端再找关系转换成另一个是不行的或者说很麻烦,在这里浪费了很多时间
// 从lin 到 rpo,分别代表中序左右端点,后序左右端点
void fun(int lin, int rin, int lpo, int rpo, int fa)
{
    if(lin >= rin)
    {
        return;
    }
    for(int i = lin; i <= rin; i++)
    {
        if(in[i] == fa)
        {
            if(i - 1 >= lin)
            fun(lin, i - 1, lpo, lpo + i - 1 - lin, mp[fa][0] = post[lpo + i - 1 - lin]);
            if(i + 1 <= rin)
            fun(i + 1, rin, lpo + i - lin, rpo - 1, mp[fa][1] = post[rpo - 1]);
        }
    }
}

// 队列实现层序遍历
queue<int> q;
void print(int s)
{
    q.push(s);
    printf("%d", s);
    while(!q.empty())
    {
        int t = q.front();
        if(t != s)
        {
            printf(" %d", t);
        }
        if(mp[t][0]) q.push(mp[t][0]);
        if(mp[t][1]) q.push(mp[t][1]);
        q.pop();
    }
}

int main()
{
    // 读入数据
    cin >> n;
    for (int i = 1; i <= (n << 1); i++)
    {
        if (i <= n)
            cin >> post[i];
        else
            cin >> in[i - n];
    }

    // 求解具体树
    fun(1, n, 1, n, post[n]);
    // 按要求层序遍历输出
    print(post[n]);
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值