【PAT】【简单大整数运算】1023 Have Fun with Numbers (20 分)

题目链接:1023 Have Fun with Numbers (20 分)

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

// raw word:

// duplication重复  permutation排列

// 解题思路:

// 不少于20个字符,也就是说最大有20位,超过了long long型,所以要用大整数运算

// 开一个数组每个num[i]模拟一个位就来计算就可以了

 

#include <iostream>
#include <cstdio>
using namespace std;

int used[10];
int num[30];
int main()
{
    // 作为字符串读入
    string a; cin >> a;
    // 转成整型单独的位到数组中,模拟乘法
    int jin = 0, n = 0;
    for(int i = 0; i < a.size(); i++, n++)
    {
        num[n] = a[a.size() - 1 - i] - '0';// 末位在前,方便进位
        used[num[n]]++;//记录原数digit使用频数
        num[n] = 2 * num[n] + jin;// 进行 *2 并且加上上位计算后的进位
        jin = 0;//归零
        // 该位计算完后,若大于9则进位
        if(num[n] >= 10)
        {
            jin = num[n] / 10;
            num[n] %= 10;
        }
    }
    bool flag = true;
    // 整个数有了进位的话,肯定不成立,因为多了一个数字
    if(jin) {num[n++] = jin; flag = false;}   
    // 开始判断
    if(flag)
    for(int i = 0; i < n; i++)
    {
        if(--used[num[i]] < 0)
        {
            flag = false;
            break;
        }
    }
    if(flag)
    for(int i = 0; i < n; i++)
    {
        if(used[num[i]])
        {
            flag = false;
            break;
        }
    }
    // 根据判断结果输出
    if(flag) printf("Yes\n");
    else printf("No\n");
    for(int i = n - 1; i >= 0; i--)
    {
        printf("%d", num[i]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值