Heavy Transportation

Background
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

Problem
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo’s place) to crossing n (the customer’s place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input
The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input
1
3 3
1 2 3
1 3 4
2 3 5

Sample Output
Scenario #1:
4

题目大意:一共有n个街角,有m条路;每条路都有最大限重;
求从街角1 到街角n的每条路径中的每两个街角的最小限重,这个限重也就是这条路的最大限重
再比较每条从 1 到 n 的路径的最大限重;
部分代码理解

   for(int j=1; j<=n; j++)
            if(!vis[j]&&dist[j]<min(dist[fla],map[fla][j]))
                dist[j]=min(dist[fla],map[fla][j]);

dist[fla]存的是从 点1 到** 点fal的所有路径中限重最大那一条路中的分段的最小限重**
map[fla][j]表示 点fla点j 之间路径的大小
如果 点fla点j 之间没有直达的路则 点fla点j 不能直接相连 不必更新dits[j]的值
如有 则 点fla点j 能直接相连 即比较 1 到 fla 的 最大限重和 点fla点j 之间的限重的大小,小的即为该条从1j 的路的最大限重
在将该条路的最大限重之前所求的到从 1 到达 j 的路径的最大限重 比较
选取两者之间的 即为从1到j 点的最大限重
简而言之 求从点1到点j的所有路径中的最大限重的最大值
好了
话不多说 上代码

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=2e4+5;
int vis[N];
int dist[N];
int map[N][N];//两点之间的距离;没有直接相连的两个点之间的距离为0
int n,m,a,b,c,d,t;
int dijkstra()
{
    memset(vis,0,sizeof(vis));//标记
    for(int i=1; i<=n; i++)
        dist[i]=map[1][i];//预先将与1直接相连的点的限重记录
        // 从1到不能直接相连的点1的限重为0;
    vis[1]=1;
    for(int i=1; i<n; i++)
    {
        int fla;
        int maxn=-1;
        for(int j=1; j<=n; j++)
            if(!vis[j]&&dist[j]>maxn)//找没有走过的最大限重最大的点
            {
                fla=j;
                maxn=dist[j];
            }
        vis[fla]=1;//找到标记
        for(int j=1; j<=n; j++)
            if(!vis[j]&&dist[j]<min(dist[fla],map[fla][j]))
                dist[j]=min(dist[fla],map[fla][j]);
    } //求到达点j的所有路径中每条路径的最大限重的最大值
    return dist[n];
}
int main()
{
    cin>>t;
    int num=1;

    while(t--)
    {
        memset(map,0,sizeof(map));
        cin>>n>>m;
        while(m--)
        {
            cin>>a>>b>>c;
            map[a][b]=c;
            map[b][a]=c;
        }
        cout<<"Scenario #"<<num<<":"<<endl;
        cout<<dijkstra()<<endl<<endl;
        num++;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值