Prime Ring Problem

Prime Ring Problem

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.

Input
n (0 < n < 20).

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.

题意描述:用1到n摆放到圆圈内,每相邻两个数之和必须是素数,按字典序输出摆放方案。

解题思路:用dfs依次摆放第x个圆圈内的数,若某个数未被使用过且与前一个摆放的数之和为素数,就可以摆放,将该数标记,再继续dfs下一个圆圈摆放什么数,当摆放到最后一个圆圈时,还要比较它+1是不是素数,每次dfs后要释放标记,便于下一种方案使用。

注意事项:第一个圆圈一定为1,最后一个圆圈需要判断加一是不是素数,方案按字典序打印。

Sample Input
6
8

Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

参考代码:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;

int judge(int m)
{
	if(m<2)
		return 0;
	int i,k=(int)sqrt(m);
	for(i=2;i<=k;i++)
		if(m%i==0)
			return 0;
	return 1;
}
int book[30],a[30];
int n;
void dfs(int x)
{
	int i;
	if(x==n)
	{
		if(judge(a[x-1]+1))
		{
			cout<<a[0];
			for(i=1;i<n;i++)
				cout<<' '<<a[i];
			cout<<endl;
		}
		return ; 
	}		
	for(i=1;i<=n;i++)
	{
		if(book[i])
		{
			if(judge(i+a[x-1]))
			{
				book[i]=0;
				a[x]=i;
				dfs(x+1);
				book[i]=1;
			}
		}	
	}
}
int main()
{
	int i,k=0;
	while(cin>>n)
	{
		printf("Case %d:\n",++k);
		memset(book,1,sizeof(book));
		a[0]=1;
		book[1]=0;
		if(n>1)
			dfs(1);
		cout<<endl;
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值