西北农林科技大学OJ (C++)字符串子串查找与判断(考察string类及其成员函数find)

Description

定义两个string类对象str1和str2,采用getline函数读入两个字符串,检测第二个字符串是否是第一个字符串的子串,若是,输出子串在主串中的位置,否则输出-1。

参考:

https://cplusplus.com/reference/string/string/find/

https://cplusplus.com/reference/string/string/getline/?kw=getline

Input

输入两个字符串。

Output

输出第二个字符串在第一个字符串中的位置,若第二个字符串不是第一个字符串的子串,则输出-1。

Sample Input 1 

3451 234a_bc
234a

Sample Output 1

5

**************************************************************************************************************

代码实现

#include <iostream>       // std::cout
#include <string>         // std::string
using namespace std;

int main ()
{
    string str1,str2;
    getline(cin,str1);
    getline(cin,str2);

    size_t found = str1.find(str2);
    if (found != string::npos)
      cout<<found<<endl;
    else
      cout<<"-1"<<endl;
    
    return 0;
}

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值