[数位dp][LIS]XHXJ‘s LIS HDU4352

#define xhxj (Xin Hang senior sister(学姐))
If you do not know xhxj, then carefully reading the entire description is very important.
As the strongest fighting force in UESTC, xhxj grew up in Jintang, a border town of Chengdu.
Like many god cattles, xhxj has a legendary life:
2010.04, had not yet begun to learn the algorithm, xhxj won the second prize in the university contest. And in this fall, xhxj got one gold medal and one silver medal of regional contest. In the next year's summer, xhxj was invited to Beijing to attend the astar onsite. A few months later, xhxj got two gold medals and was also qualified for world's final. However, xhxj was defeated by zhymaoiing in the competition that determined who would go to the world's final(there is only one team for every university to send to the world's final) .Now, xhxj is much more stronger than ever,and she will go to the dreaming country to compete in TCO final.
As you see, xhxj always keeps a short hair(reasons unknown), so she looks like a boy( I will not tell you she is actually a lovely girl), wearing yellow T-shirt. When she is not talking, her round face feels very lovely, attracting others to touch her face gently。Unlike God Luo's, another UESTC god cattle who has cool and noble charm, xhxj is quite approachable, lively, clever. On the other hand,xhxj is very sensitive to the beautiful properties, "this problem has a very good properties",she always said that after ACing a very hard problem. She often helps in finding solutions, even though she is not good at the problems of that type.
Xhxj loves many games such as,Dota, ocg, mahjong, Starcraft 2, Diablo 3.etc,if you can beat her in any game above, you will get her admire and become a god cattle. She is very concerned with her younger schoolfellows, if she saw someone on a DOTA platform, she would say: "Why do not you go to improve your programming skill". When she receives sincere compliments from others, she would say modestly: "Please don’t flatter at me.(Please don't black)."As she will graduate after no more than one year, xhxj also wants to fall in love. However, the man in her dreams has not yet appeared, so she now prefers girls.
Another hobby of xhxj is yy(speculation) some magical problems to discover the special properties. For example, when she see a number, she would think whether the digits of a number are strictly increasing. If you consider the number as a string and can get a longest strictly increasing subsequence the length of which is equal to k, the power of this number is k.. It is very simple to determine a single number’s power, but is it also easy to solve this problem with the numbers within an interval? xhxj has a little tired,she want a god cattle to help her solve this problem,the problem is: Determine how many numbers have the power value k in [L,R] in O(1)time.
For the first one to solve this problem,xhxj will upgrade 20 favorability rate。

Input

First a integer T(T<=10000),then T lines follow, every line has three positive integer L,R,K.(
0<L<=R<263-1 and 1<=K<=10).

Output

For each query, print "Case #t: ans" in a line, in which t is the number of the test case starting from 1 and ans is the answer.

Sample Input

1
123 321 2

Sample Output

Case #1: 139 

题意: 给出l,r,k,求区间[l, r]内最长上升子序列长度为k的数字个数。例如样例中131就是符合条件的数字。

分析: 因为是统计数字个数的问题,显然要用到数位dp,而且还涉及到最长上升子序列,还需要考虑求LIS的思想。这道题比较难想到的点是把已经选好的子序列状压到一个整数上,这样就可以把它作为状态加入到dp数组中。在数位dp计数部分要区分是否有前导零,分两种情况讨论即可,有前导零的情况比较简单,不多说了,无前导零的情况就是一个求最长上升子序列的思想,看代码很容易理解。

具体代码如下: 

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#define int long long
using namespace std;
//比较难想到把选好的LIS状压 
int dp[70][1<<10][2][10], l, r, k, a[70];

int dfs(int pos, int LIS, int num, int flag, int lead, int k)
{
	if(pos == 0)
		return num == k;
	if(flag && dp[pos][LIS][lead][k] != -1)
		return dp[pos][LIS][lead][k];
	int ans = 0, up = flag ? 9 : a[pos];
	for(int i = 0; i <= up; i++)
	{
		if(!lead && i == 0)//有前导零的情况 
			ans += dfs(pos-1, LIS, num, flag||i<up, lead||i!=0, k);
		else
		{
			int t = 0, cpy = LIS;//接下来就是求最长上升子序列过程 
			for(int j = i; j <= 9; j++)//找到第一个大于等于当前值的数字,替换掉它 
			{
				if((cpy>>j)&1)
				{
					t = 1;
					cpy = cpy^(1<<j);
					cpy = cpy|(1<<i);
					break;
				}
			}
			if(!t)//如果自己是最大的 
				cpy = cpy|(1<<i);
			ans += dfs(pos-1, cpy, num+(!t), flag||i<up, lead||i!=0, k);
		}
	}
	if(flag)
		dp[pos][LIS][lead][k] = ans;
	return ans;
}

int solve(int x)
{
	int pos = 0;
	do
	{
		a[++pos] = x%10;
		x /= 10;
	}while(x);
	return dfs(pos, 0, 0, 0, 0, k);
} 

signed main()
{
	int T;
	cin >> T;
	memset(dp, -1, sizeof dp);
	for(int i = 1; i <= T; i++)
	{
		scanf("%lld%lld%lld", &l, &r, &k);
		printf("Case #%lld: %lld\n", i, solve(r)-solve(l-1));
	}
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值