[好题][反向建图]Invitation Cards POJ1511

In the age of television, not many people attend theater performances. Antique Comedians of Malidinesia are aware of this fact. They want to propagate theater and, most of all, Antique Comedies. They have printed invitation cards with all the necessary information and with the programme. A lot of students were hired to distribute these invitations among the people. Each student volunteer has assigned exactly one bus stop and he or she stays there the whole day and gives invitation to people travelling by bus. A special course was taken where students learned how to influence people and what is the difference between influencing and robbery.

The transport system is very special: all lines are unidirectional and connect exactly two stops. Buses leave the originating stop with passangers each half an hour. After reaching the destination stop they return empty to the originating stop, where they wait until the next full half an hour, e.g. X:00 or X:30, where 'X' denotes the hour. The fee for transport between two stops is given by special tables and is payable on the spot. The lines are planned in such a way, that each round trip (i.e. a journey starting and finishing at the same stop) passes through a Central Checkpoint Stop (CCS) where each passenger has to pass a thorough check including body scan.

All the ACM student members leave the CCS each morning. Each volunteer is to move to one predetermined stop to invite passengers. There are as many volunteers as stops. At the end of the day, all students travel back to CCS. You are to write a computer program that helps ACM to minimize the amount of money to pay every day for the transport of their employees.

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case begins with a line containing exactly two integers P and Q, 1 <= P,Q <= 1000000. P is the number of stops including CCS and Q the number of bus lines. Then there are Q lines, each describing one bus line. Each of the lines contains exactly three numbers - the originating stop, the destination stop and the price. The CCS is designated by number 1. Prices are positive integers the sum of which is smaller than 1000000000. You can also assume it is always possible to get from any stop to any other stop.

Output

For each case, print one line containing the minimum amount of money to be paid each day by ACM for the travel costs of its volunteers.

Sample Input

2
2 2
1 2 13
2 1 33
4 6
1 2 10
2 1 60
1 3 20
3 4 10
2 4 5
4 1 50

Sample Output

46
210

题意: n-1个人从1号点出发,到剩余n-1个宣传点,然后再回到1号点汇报结果,求所有人往返路径和的最小值。所有路径都是单向的。

分析: 由于是单向边,就不能跑一遍最短路然后每个点最短距离乘2相加了。对于n-1个人从1号点回去时正向建图跑一边dijkstra,对于n-1个人去1号点时需要反向建边,再跑一遍dijkstra,此时从1号点到i号点的最短路就是从i号点走到1号点的最短路,反证法可以很容易得出结论正确性。这道题由于边数点数都是1e6级别的,必须要跑堆优化的dijkstra,而且最好是用链式前向星存图,这样不容易T掉。最后记得开long long!

具体代码如下: 

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <queue>
#include <utility>
#define int long long
#define inf 0x3f3f3f3f
#define pii pair<int, int>
using namespace std;
//正向建图+反向建图 
int n, m, cnt, head[1000005], vis[1000005], dis[1000005], u[1000005], v[1000005], w[1000005];
struct edge
{
	int to, next, w;
}edge[1000005];

void add(int u, int v, int w)
{
	edge[++cnt].to = v;
	edge[cnt].w = w;
	edge[cnt].next = head[u];
	head[u] = cnt;	
}

void dijkstra()
{
	priority_queue<pii, vector<pii>, greater<pii> > a;
	dis[1] = 0;
	a.push(make_pair(0, 1));
	while(a.size())
	{
		int now = a.top().second;
		a.pop();
		if(vis[now])
			continue;
		vis[now] = true;
		for(int i = head[now]; i; i = edge[i].next)
		{
			int to = edge[i].to;
			if(dis[to] > dis[now]+edge[i].w)
			{
				dis[to] = dis[now]+edge[i].w;
				a.push(make_pair(dis[to], to));
			}
		}
	}
}

signed main()
{
	int T;
	cin >> T;
	while(T--)
	{
		scanf("%lld%lld", &n, &m);
		for(int i = 1; i <= n; i++)
			vis[i] = head[i] = 0, dis[i] = inf;
		cnt = 0;
		for(int i = 1; i <= m; i++)
		{
			scanf("%lld%lld%lld", &u[i], &v[i], &w[i]);
			add(u[i], v[i], w[i]);
		}
		dijkstra();
		int ans = 0;
		for(int i = 2; i <= n; i++)
			ans += dis[i];
		//反向建图再跑一遍 
		for(int i = 1; i <= n; i++)
			vis[i] = head[i] = 0, dis[i] = inf;
		cnt = 0;
		for(int i = 1; i <= m; i++)
			add(v[i], u[i], w[i]);
		dijkstra();
		for(int i = 2; i <= n; i++)
			ans += dis[i];
		printf("%lld\n", ans);
	}
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值