[n串的最长公共子串][后缀数组]Corporate Identity POJ3450

23 篇文章 0 订阅
22 篇文章 0 订阅

Beside other services, ACM helps companies to clearly state their “corporate identity”, which includes company logo but also other signs, like trademarks. One of such companies is Internet Building Masters (IBM), which has recently asked ACM for a help with their new identity. IBM do not want to change their existing logos and trademarks completely, because their customers are used to the old ones. Therefore, ACM will only change existing trademarks instead of creating new ones.

After several other proposals, it was decided to take all existing trademarks and find the longest common sequence of letters that is contained in all of them. This sequence will be graphically emphasized to form a new logo. Then, the old trademarks may still be used while showing the new identity.

Your task is to find such a sequence.

Input

The input contains several tasks. Each task begins with a line containing a positive integer N, the number of trademarks (2 ≤ N ≤ 4000). The number is followed by N lines, each containing one trademark. Trademarks will be composed only from lowercase letters, the length of each trademark will be at least 1 and at most 200 characters.

After the last trademark, the next task begins. The last task is followed by a line containing zero.

Output

For each task, output a single line containing the longest string contained as a substring in all trademarks. If there are several strings of the same length, print the one that is lexicographically smallest. If there is no such non-empty string, output the words “IDENTITY LOST” instead.

Sample Input

3
aabbaabb
abbababb
bbbbbabb
2
xyz
abc
0

Sample Output

abb
IDENTITY LOST

题意: 求n个字符串的最长公共子串。

分析: 刚学后缀数组时感觉还挺难的,现在做了这么多题后这道就和模板差不多了,先把n个串用不同的分隔符连接起来,之后跑一遍后缀数组得到height值,然后二分公共子串的长度len,check时用一个桶记录每一段height值大于等于len的区间是否来自n个不同的字符串,如果存在这样的区间返回true,若不存在就返回false。

得到最长公共子串长度len后直接在排序后的后缀上找一段height值大于等于len的区间,同样判断这段区间是否来自n个不同的字符串,由于优先输出字典序小的子串,当我们找到第一个符合条件的子串时直接输出并跳出循环。

需要注意特判一下字符串数量为1的情况!!!

具体代码如下:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#define inf 0x3f3f3f3f
using namespace std;

int a[200005]; 

signed main()
{
	int n;
	cin >> n;
	for(int i = 1; i <= n; i++)
		scanf("%d", &a[i]);
	int _min = inf, *t1;
	for(int i = 1; i <= n; i++)
	{
		if(_min >= a[i])
		{
			_min = a[i];
			t1 = a+i;
		}
	}
	t1++;
	if(t1-a >= n-1)
	{
		int _min = inf;
		for(int i = 1; i <= n-2; i++)
		{
			if(_min >= a[i])
			{
				_min = a[i];
				t1 = a+i;
			}
		}
		t1++;
	}
	reverse(a+1, t1);
	_min = inf;
	int *t2;
	for(int i = t1-a; i <= n; i++)
	{
		if(_min >= a[i])
		{
			_min = a[i];
			t2 = a+i;
		}
	}
	t2++;
	if(t2-a >= n)
	{
		int _min = inf;
		for(int i = t1-a; i <= n-1; i++)
		{
			if(_min >= a[i])
			{
				_min = a[i];
				t2 = a+i;
			}
		}
		t2++;
	}
	reverse(t1, t2);
	reverse(t2, a+n+1);
	for(int i = 1; i <= n; i++)
		printf("%d\n", a[i]);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值