[二分][叉积]TOYS POJ2318

41 篇文章 2 订阅
23 篇文章 0 订阅

Calculate the number of toys that land in each bin of a partitioned toy box.
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys.

John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box.


For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

Hint

As the example illustrates, toys that fall on the boundary of the box are "in" the box.

题意: 如图,存在一个矩形收纳柜,现在有m个隔板,n个点,给出矩形边界坐标,各隔板坐标,各点坐标,求隔板分割出来的m+1个区域内分别存在几个点,假设所有点均在矩形区域内。

分析: 计算几何基础题,利用叉积判区域的性质,如果两向量叉乘为正,则点在线段左侧,否则在线段右侧。如下图所示,要想判断p点在线段l左侧还是右侧只需要知道两向量叉乘的符号即可。

之后就可以二分找到点p右侧第一条直线,记录答案,如果没有找到,说明点p在最右侧的区域里,同样记录答案。

具体代码如下:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;

struct Point
{
	double x, y;
	Point(){}
	Point(double tx, double ty):x(tx), y(ty){}
	double operator ^(const Point &b)const//叉乘 
	{
		return x*b.y - y*b.x;
	}
}p[5005];

struct Line
{
	Point s, e;
	Line(){}
	Line(Point ts, Point te):s(ts), e(te){}
}l[5005];

bool check(int line, int point)
{
	//用点代替向量 
	Point t1(l[line].e.x-l[line].s.x, l[line].e.y-l[line].s.y);
	Point t2(p[point].x-l[line].s.x, p[point].y-l[line].s.y);
	return (t2^t1)>0?true:false;
}

int res[5005];

signed main()
{
	int n, m, sx, sy, ex, ey;
	while(~scanf("%d", &m))
	{
		if(m == 0)
			break;
		scanf("%d%d%d%d%d", &n, &sx, &sy, &ex, &ey);
		for(int i = 0; i <= m; i++)
			res[i] = 0;
		for(int i = 1; i <= m; i++)
		{
			double tx;
			scanf("%lf", &tx);
			Point p1(tx, sy);
			scanf("%lf", &tx);
			Point p2(tx, ey);
			Line t(p1, p2);
			l[i] = t;
		}
		for(int i = 1; i <= n; i++)
		{
			double tx, ty;
			scanf("%lf%lf", &tx, &ty);
			Point t(tx, ty);
			p[i] = t;
		}
		for(int i = 1; i <= n; i++)//利用叉乘二分每个点所在区域 
		{
			int l = 1, r = m, ans = -1;
			while(l <= r)
			{
				int mid = l+r>>1;
				if(check(mid, i))
				{
					ans = mid;
					r = mid-1;
				}
				else
					l = mid+1;
			}
			if(ans != -1)
				res[ans-1]++;
			else
				res[m]++;
		} 
		for(int i = 0; i <= m; i++)
			printf("%d: %d\n", i, res[i]);
		puts("");
	}
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值