模拟——Phone numbers

Phone numbers

题面翻译

题面描述

给一串长度为 n n n 的数字串,在两个或三个数字之间加-,使得这个数字串便于记忆。如果有多解,可随意输出其中一个。

数据范围与约定

2 ≤ n ≤ 100 2\leq n\leq 100 2n100

题目描述

Phone number in Berland is a sequence of $ n $ digits. Often, to make it easier to memorize the number, it is divided into groups of two or three digits. For example, the phone number 1198733 is easier to remember as 11-987-33. Your task is to find for a given phone number any of its divisions into groups of two or three digits.

输入格式

The first line contains integer $ n $ ( $ 2<=n<=100 $ ) — amount of digits in the phone number. The second line contains $ n $ digits — the phone number to divide into groups.

输出格式

Output any of divisions of the given phone number into groups of two or three digits. Separate groups by single character -. If the answer is not unique, output any.

样例 #1

样例输入 #1

6
549871

样例输出 #1

54-98-71

样例 #2

样例输入 #2

7
1198733

样例输出 #2

11-987-33

代码

#include<iostream>

using namespace std;

int n;
string a;
bool f;

int main(){
    cin>>n>>a;
    
    if(n&1){
        f=true;
    }
    
    for(int i=0;i<n;i++){
        if(i&1&&i!=n-1){
            if(i==n-2&&f){
                cout<<a[i];
            }else cout<<a[i]<<'-';
        }else{
            cout<<a[i];   
        }
    }
    
    return 0;
}
  • 4
    点赞
  • 9
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

green qwq

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值