<数据结构浙大>03-树2 List Leaves (25 分)

//一个简单的层序遍历

Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in one line all the leaves' indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

结尾无空行

Sample Output:

4 1 5

结尾无空行

程序代码:

#include <iostream>
#include <queue>
#define MaxSize 10
using namespace std;
typedef struct TreeNode{
	int index;
	int left;
	int right;
};
TreeNode T1[MaxSize];
queue<TreeNode>q;

int main() {
	int n;
	scanf("%d", &n);
	int i;
	int* check = new int[n];//动态分配数组
	for (i = 0; i < n; i++)//初始化该数组=0
	{
		check[i] = 0;
	}
	for (i = 0; i < n; i++)
	{
		char cl, cr;
		T1[i].index = i;
		scanf("\n%c %c", &cl, &cr);//注意输入格式 要有空格 并且要有回车!!!
		if (cl == '-')
		{
			T1[i].left = -1;
		}
		else {
			T1[i].left = cl - '0';
			check[T1[i].left] = 1; //标记
		}
		if (cr == '-')
		{
			T1[i].right = -1;
		}
		else {
			T1[i].right = cr - '0';
			check[T1[i].right] = 1;
		}
	}
	int root = -1;
	for (i = 0; i < n; i++)
	{
		if (check[i] == 0) {
			root = i;
			break;
		}
	}
	delete[] check;
	//层序遍历
	q.push(T1[root]);
	int count = 0;
	while (!q.empty())
	{
		TreeNode heel = q.front();
		q.pop();
		if (heel.left != -1)
			q.push(T1[heel.left]);
		if (heel.right != -1)
			q.push(T1[heel.right]);
		if (heel.left == -1 && heel.right == -1)
		{
			if (count == 0)//设置count 就为了输出第一个节点时前面不加空格,后面都是“空格 index”
			{
				printf("%d", heel.index);
				count = 1;
			}
			else printf(" %d", heel.index);
		}
	}
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

zbc-

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值