<数据结构浙大>03-树3 Tree Traversals Again (25 分)

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

结尾无空行

Sample Output:

3 4 2 6 5 1

结尾无空行

思路:

        push的顺序对应前序遍历,pop的顺序对应中序遍历(因为这是在模拟中序遍历的非递归算法,先要解决的后进栈)。

        方法:已知前序和中序遍历,建立一棵二叉树,然后进行后序遍历;

     

程序代码:

#include <iostream>
#include<stack>
using namespace std;
typedef struct TreeNode{
	int data;
	struct TreeNode* left;
	struct TreeNode* right;
}TreeNode,*Tree;
int flag = 0;

Tree CreateTree(int n, int* pre, int* in)
{
	if (n == 0) return NULL;
	Tree T = new TreeNode();
	T->data = pre[0];
	T->left = T->right = NULL;
	int i;
	for (i = 0; i < n; i++)//在中序遍历中找到根节点,左根右,i的值其实就是该结点的左子树的总结点数
	{
		if (pre[0] == in[i])
			break;
	}
	T->left = CreateTree(i, pre + 1, in);
	T->right = CreateTree(n - i - 1, pre + i + 1, in + i + 1);
	/*拿第一次为例
		pre[3,2,4,1,6,5] 根左右,根结点为1,左子树就是3,2,4,所以传入n=i=3,左子树的根节点就是pre+1(根结点的下一个)
			由于左子树所在数组为[3,2,4],对其遍历时i[0]依然为3,所以传入in,用来确定下一个根节点的左子树结点个数
		in[3,2,4,1,6,5] 左根右,根结点为1,右子树就是6,5,右子树的根节点是5,传入5的位置pre+i+1=4
			遍历时需要让新的in[0]=旧的in[4],所以传入in+i+1=4
	*/
	return T;
}
void Postolder(Tree T)
{
	
	if (!T) return;
	Postolder(T->left);
	Postolder(T->right);
	if (flag == 0)
	{
		flag = 1;
		cout <<T->data;
	}
	else cout<< " " <<T->data;
}

int main()
{
	int n;
	stack<int>st;
	cin >> n;
	int *pre=new int[n], *in=new int[n];
	string s;
	int num ;
	int index1 = 0, index2 = 0;
	for (int i = 0; i < 2*n; i++)
	{
		cin >> s;
		if (s == "Push") 
		{
			cin >> num;
			pre[index1++] = num; 
			st.push(num);
		}
		if (s == "Pop")
		{
			in[index2++] = st.top();
			st.pop();
		}
	}
	Tree tree = CreateTree(n, pre, in);
	
	Postolder(tree);
	delete[] pre; delete[] in;
	return 0;

}

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

zbc-

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值