2164: 括号匹配

题目描述

给你一个字符串,里面只有两种字符"("和")"。问是否所有"("都有一个")"与之匹配。

输入描述

第一行一个数字T (0<T<=100),表示T组测试数据。

随后T组测试数据,每组测试数据一个字符串str。(0 <= strlen(str) <= 10000)

输出描述

对于每组测试数据,如果字符串中所有"("都有一个")"与之匹配,则输出"yes", 否则输出"no"

Sample Input

2

(())

)(

Sample Output

yes

no

 通过栈操作:

#include<iostream>
#include<cstring>
#include<stack>
using namespace std;
bool func(char str[])
{
 	char temp; 
    stack<char>s;
    for (int i=0;i<strlen(str);i++)
    {
    	//如果为左括号入栈 
        if (str[i]=='(')
            s.push(str[i]);
        else
        {
            if (s.empty())
                return false;
            if (s.top()=='('&&str[i]==')')
                s.pop();
            else
                return false;
        }
    }
    //如果栈空说明没有括号剩余 
    if (s.empty())
        return true;
    return false;
}
int main(void)
{
	int n;
	cin>>n;
	char str[10001];
	while(n--)
	{
		cin>>str;
		if(func(str))
		{
			cout<<"yes"<<endl;
		}
		else
		{
			cout<<"no"<<endl;
		}
	}
	return 0;
 } 

count计数:

#include<iostream>
#include<cstring> 
using namespace std; 
bool judge(char str[])
{
    int count=0;
    for(int i=0;i<strlen(str);i++)
    {
        if(str[i]=='(')
        {
            count++;
        }
        else
        {
            count--;
        }
        if(count<0)
            return false;
    }
    if(count==0)
        return true;
    else
        return false;
}
int main(void)
{
    int n,count=0,flag=0;
    cin>>n;
    while(n--)
    {
        char str[10001];
        cin>>str;
        if(judge(str))
        {
            cout<<"yes"<<endl;
        }
        else
        {
            cout<<"no"<<endl;
        }
    }
    return 0;
}
  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ლ旺旺掀被

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值