PTA 甲级 1011 World Cup Betting(C++)

准大二小白在学技术的同时每天至少一道算法题,以此督促自己,共勉!

1011 World Cup Betting

分数 20

全屏浏览题目

切换布局

作者 CHEN, Yue

单位 浙江大学

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

For example, 3 games' odds are given as the following:

 W    T    L
1.1  2.5  1.7
1.2  3.1  1.6
4.1  1.2  1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%−1)×2=39.31 yuans (accurate up to 2 decimal places).

Input Specification:

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to WT and L.

Output Specification:

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input:

1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

Sample Output:

T T W 39.31

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

#include<bits/stdc++.h>
using namespace std;
//每场比赛胜平败对应利率
double eachProfit[4];
//每场比赛最大利率
double eachMaxProfit[4];
 //三局比赛最大比率的乘积*0.65-1再*2
double allMax=1.0;   
//标记每场比赛最大利率对应索引
int temp;    
int main(){
    for(int i=1;i<=3;i++){
        double max1=-1.0;
        for(int j=1;j<=3;j++){
            cin>>eachProfit[j];
        }
        for(int k=1;k<=3;k++){
            if(eachProfit[k]>max1){
                max1=eachProfit[k];
                temp=k;
            }
        }
        eachMaxProfit[i]=eachProfit[temp];
        allMax*=eachProfit[temp];
        if(temp==1){
            printf("W ");
        }
        else if(temp==2){
            printf("T ");
        }
        else printf("L ");
    }
    printf("%.2f",(allMax*0.65-1)*2);
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Silver Vortex

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值