Largest Rectangle in a Histogram POJ2559—暴力枚举

Description

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:


Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input

The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1<=n<=100000. Then follow n integers h1,...,hn, where 0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

Output

For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input

7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output

8
4000

Hint

Huge input, scanf is recommended.

翻译:

    有一些连续的矩形,他们的宽度都是一个单位,高度各不相同.
    从这些连续的矩形中截取一个规则的矩形,截取出来的矩形最多能有多大(指面积.

输入:

    有多组输入数据.
    每一行第一个数字为一个整数n,代表这组数据有多少个矩形
    然后是n个数字,代表每个矩形的高度.
    当n为0时结束.

输出:

    对于每一组数据,输出所截的矩形的面积最大有多大.

法一:暴力

以高为固定进行遍历,遇到高度小于该高度停止,从第一个矩形开始暴力枚举,高度自低而高暴力枚举;

#include<bits/stdc++.h>
using namespace std;
const int N=1000010;
int arr[N];
int main(){
	int n;
	while (cin>>n&&n){
		int max1=0;//记录最高的矩形高度 
		for(int i=0;i<n;i++){
			cin>>arr[i];
			if(arr[i]>max1) max1=arr[i];
		}
		cout<<"最高的矩形高度"<<max1<<endl;
		int len=1;//初始底边长度为1; 
		int s;
		int ans=0;
		for(int high=1;high<=max1;high++){
			for(int j=0;j<n;j++){
			if(arr[j]>=high) {
            len++;
			}
			if(arr[j]<high||j==n-1) {
				s=high*len;
				cout<<"当前面积是"<<s<<endl; 
                len=0; 
				if(s>ans) {
				ans=s;
				}
			}
		}
	}
	cout<<ans<<endl;
}
return 0;
}

没有进行oj测试,只是自己写着玩的,样例可以过。

法二:栈——太难。

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ou_fan

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值