21.Rectangles

Problem-2056

Problem Description

Given two rectangles and the coordinates of two points on the diagonals of each rectangle,you have to calculate the area of the intersected part of two rectangles. its sides are parallel to OX and OY .

给定两个矩形和每个矩形对角线上两个点的坐标,你必须计算两个矩形相交部分的面积。其侧面平行于OX和OY。  

Input

Input The first line of input is 8 positive numbers which indicate the coordinates of four points that must be on each diagonal.The 8 numbers are x1,y1,x2,y2,x3,y3,x4,y4.That means the two points on the first rectangle are(x1,y1),(x2,y2);the other two points on the second rectangle are (x3,y3),(x4,y4).

 输入第一行输入是8个正数,表示每个对角线上必须有四个点的坐标。这8个数字是x1、y1、x2、y2、x3、y3、x4、y4。这意味着第一个矩形上的两个点是(x1,y1)、(x2,y2);第二矩形上的另外两个点是(x3,y3),(x4,y4)。

Output

Output For each case output the area of their intersected part in a single line.accurate up to 2 decimal places.

 输出对于每种情况,在一行中输出其相交部分的面积。精确到小数点后2位。

Sample Input

1.00 1.00 3.00 3.00 2.00 2.00 4.00 4.00

5.00 5.00 13.00 13.00 4.00 4.00 12.50 12.50

Sample Output

1.00

56.25

 相交面积的计算:

 不想交情况的判断:注意||判断的条件顺序

||判断原则:从左往右判断,碰到真直接返回true后面不管,是假一直判断到后面,直到全部语句                        判断完

 

#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;

int main()
{
	double x1, y1, x2, y2, x3, y3, x4, y4;
	while (cin >> x1 >> y1 >> x2 >> y2 >> x3 >> y3 >> x4 >> y4)
	{
		if (x3>=x2||x4<=x1||y3>=y2||y4<=y1)
		{
			cout << "0.00" << endl;
		}
		else
		{
			vector<double> vx(4, 0.00);
			vx[0] = x1; vx[1] = x2; vx[2] = x3; vx[3] = x4;
			sort(vx.begin(), vx.end());

			vector<double> vy(4, 0.00);
			vy[0] = y1; vy[1] = y2; vy[2] = y3; vy[3] = y4;
			sort(vy.begin(), vy.end());

			printf("%.2lf\n", (vx[2] - vx[1]) * (vy[2] - vy[1]));
		}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值