杭电 1865 1string

1sting

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4155    Accepted Submission(s): 1563


Problem Description
You will be given a string which only contains ‘1’; You can merge two adjacent ‘1’ to be ‘2’, or leave the ‘1’ there. Surly, you may get many different results. For example, given 1111 , you can get 1111, 121, 112,211,22. Now, your work is to find the total number of result you can get.
 

Input
The first line is a number n refers to the number of test cases. Then n lines follows, each line has a string made up of ‘1’ . The maximum length of the sequence is 200.
 

Output
The output contain n lines, each line output the number of result you can get .
 

Sample Input
  
  
3 1 11 11111
 

Sample Output
  
  
1 2 8
 
 
 
本题主要考察大数斐波拉契数列 按照一般的做法来写数据会溢出
已AC代码:
#include<stdio.h>
#include<string.h>
int main()
{
	int a[201][100];
	char b[1001];
	int len,c,m,n,i,j;
	memset(a,0,sizeof(a));
	a[1][0]=1,a[2][0]=2;
	for(c=0,i=3;i<201;i++)
	{
		for(m=0,j=0;j<=100;j++)
		{
			c=a[i-1][j]+a[i-2][j]+m;
			a[i][j]=c%10;//不断取余将所求之和用二维数组存储起来 
			m=c/10;
		}
	}
	int s,l,k;
	scanf("%d",&s);
	getchar();
	while(s--)
	{
		gets(b);
		len=strlen(b);
		for(i=99,k=0;i>=0;i--)
		{
			if(a[len][i]!=0)//通过输入1的个数来找到相应的值所在二维数组的位置 
			k++;
			if(k!=0)
			printf("%d",a[len][i]);
		}
		printf("\n");
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值