hdoj1865 1string(大数,打表,大数斐波那契数列)

117 篇文章 0 订阅
4 篇文章 0 订阅
Problem Description
You will be given a string which only contains ‘1’; You can merge two adjacent ‘1’ to be ‘2’, or leave the ‘1’ there. Surly, you may get many different results. For example, given 1111 , you can get 1111, 121, 112,211,22. Now, your work is to find the total number of result you can get.
 

Input
The first line is a number n refers to the number of test cases. Then n lines follows, each line has a string made up of ‘1’ . The maximum length of the sequence is 200.
 

Output
The output contain n lines, each line output the number of result you can get .
 

Sample Input
  
  
3 1 11 11111
 

Sample Output
  
  
1 2

8

代码:

#include<stdio.h>
#include<string.h>
int a[202][102];
void fun()
{
    int i,j,k;
    memset(a,0,sizeof(a));
    a[1][0]=1;
    a[2][0]=2;
    for(i=3;i<=200;i++)
    {
         k=0;
        for(j=0;j<=100;j++)
        {
            a[i][j]=a[i-1][j]+a[i-2][j]+k;
            k=a[i][j]/10;
            a[i][j]=a[i][j]%10;
        }
    }
}
int main()
{
    fun();
    int n,i,j;
    scanf("%d",&n);
    while(n--)
    {
    char b[202];
    getchar();
    scanf("%s",b);
    int p=strlen(b);
    for(i=100;i>=0;i--)
    {
        if(a[p][i]!=0)
        break;
    }
    for( j=i;j>=0;j--)
    printf("%d",a[p][j]);
    printf("\n");
    }
    return 0;
}

思路:

用二维数组保存数据打表,第一位代表第n个,第二位表示该数的各个位数。最后找到共有多少位,输出结果。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值