LIS 最长递增子序列 hdu 5773

题意:

给你一个长度为10W的数组,每个数范围0-100W其中的0可以变为INT范围内的任意值问最长上升子序列的长度

思路:

0可以转化成任意整数,包括负数,显然求LIS时尽量把0都放进去必定是正确的。因此我们可以把0拿出来,对剩下的做O(nlogn)的LIS,统计结果 的时候再算上0的数量。为了保证严格递增,我们可以将每个权值S[i]减去i前面0的个数,再做LIS,就能保证结果是严格递增的。当时自己写的时候一直wa,忘了在函数求最长递增子序列时初始值是1,,但当遇到数全是0时,,就应该只输出0的个数即可。。。 

Problem Description
?? gets an sequence S with n intergers(0 < n <= 100000,0<= S[i] <= 1000000).?? has a magic so that he can change 0 to any interger(He does not need to change all 0 to the same interger).?? wants you to help him to find out the length of the longest increasing (strictly) subsequence he can get.
 

Input
The first line contains an interger T,denoting the number of the test cases.(T <= 10)
For each case,the first line contains an interger n,which is the length of the array s.
The next line contains n intergers separated by a single space, denote each number in S.
 

Output
For each test case, output one line containing “Case #x: y”(without quotes), where x is the test case number(starting from 1) and y is the length of the longest increasing subsequence he can get.
 

Sample Input
  
  
2 7 2 0 2 1 2 0 5 6 1 2 3 3 0 0
 

Sample Output
  
  
Case #1: 5 Case #2: 5
Hint
In the first case,you can change the second 0 to 3.So the longest increasing subsequence is 0 1 2 3 5.
 
#include<stdio.h>
#include<string.h>
int a[1000020];
int d[1000020];
int we(int key,int *d,int l,int h)
{
    while(l<=h)
    {
        int mid=(l+h)>>1;
        if(key>d[mid]&&key<=d[mid+1])
        {
            return mid;
        }
        else if(key>d[mid])
        {
            l=mid+1;
        }
        else
        {
            h=mid-1;
        }
    }
    return 0;
}
int ni(int *a,int n,int *d)
{
    int i,j;
    d[1]=a[1];
    int len=1;
    for(int i=2;i<=n;i++)
    {
        if(d[len]<a[i])
            j=++len;
        else
        {
           j=we(a[i],d,1,len)+1;
        }

        d[j]=a[i];
    }
    return len;
}
int main()
{
    int n,maxx,l,z=0;
    scanf("%d",&n);
    while(n--)
    {
        maxx=0;
        memset(a,0,sizeof(a));
        memset(d,0,sizeof(d));
           z++;
        scanf("%d",&l);
        int w=0,t,cnt=0;
        for(int i=1;i<=l;i++)
        {
        scanf("%d",&t);
        if(t==0)
            cnt++;
        else
            a[++w]=t-cnt;
        }
        if(cnt==l)
            maxx=0;
        else
        maxx=ni(a,w,d);
        //printf("%d\n",maxx);
            printf("Case #%d: %d\n",z,maxx+cnt);

    }
}

                                                             


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值